summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/thunderbird/thunderbird-78.3.1.ebuild')
-rw-r--r--mail-client/thunderbird/thunderbird-78.3.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/mail-client/thunderbird/thunderbird-78.3.1.ebuild b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
index 16934b765b02..ffd926e975ba 100644
--- a/mail-client/thunderbird/thunderbird-78.3.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-78.3.1.ebuild
@@ -561,7 +561,11 @@ src_configure() {
mozconfig_add_options_ac '+debug' --disable-optimize
else
if is-flag '-g*' ; then
- mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ if use clang ; then
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')
+ else
+ mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols
+ fi
else
mozconfig_add_options_ac 'Gentoo default' --disable-debug-symbols
fi