summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/dcc/files/dcc-1.3.158-clang16.patch')
-rw-r--r--mail-filter/dcc/files/dcc-1.3.158-clang16.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/mail-filter/dcc/files/dcc-1.3.158-clang16.patch b/mail-filter/dcc/files/dcc-1.3.158-clang16.patch
new file mode 100644
index 000000000000..adf518944408
--- /dev/null
+++ b/mail-filter/dcc/files/dcc-1.3.158-clang16.patch
@@ -0,0 +1,30 @@
+configure.ac is missing, so need to edit this manually
+
+https://bugs.gentoo.org/870646
+--- a/configure
++++ b/configure
+@@ -796,3 +796,3 @@
+
+-main(){return(0);}
++int main(void){return(0);}
+ EOF
+@@ -1100,3 +1100,3 @@
+ #include "confdefs.h"
+-main()
++int main(void)
+ {exit(sizeof(void*)==8 ? 0 : sizeof(void*));}
+@@ -1463,3 +1463,3 @@
+ #include <sys/types.h>
+-main()
++int main(void)
+ {
+@@ -3330,3 +3330,3 @@
+ #define min(a,b) ((a) < (b) ? (a) : (b))
+-main()
++int main(void)
+ {
+@@ -3596,3 +3596,3 @@
+ #include "include/dcc_paths.h"
+-main()
++int main(void)
+ {