summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild')
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild
deleted file mode 100644
index f31bfcef8aa9..000000000000
--- a/mail-filter/pypolicyd-spf/pypolicyd-spf-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# See bug #559364 before getting clever with this.
-PYTHON_COMPAT=( python3_4 )
-
-# The built-in ipaddress module handles the parsing of IP addresses. If
-# python is built without ipv6 support, then ipaddress can't parse ipv6
-# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
-# other words, it's completely broken.
-PYTHON_REQ_USE="ipv6"
-
-inherit distutils-r1
-
-DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
-HOMEPAGE="https://launchpad.net/${PN}"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=dev-python/pyspf-2.0.9[${PYTHON_USEDEP}]"
-
-RDEPEND="${DEPEND}
- dev-python/authres[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
-
-python_prepare_all() {
- # The "real" config file mentions the commented one, so we point
- # users in the right direction.
- local oldconf="policyd-spf.conf.commented"
- local newconf="/usr/share/doc/${PF}/${oldconf}"
-
- sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
- || die 'failed to update commented config file path'
-
- distutils-r1_python_prepare_all
-}