summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/rspamd/rspamd-9999.ebuild')
-rw-r--r--mail-filter/rspamd/rspamd-9999.ebuild55
1 files changed, 33 insertions, 22 deletions
diff --git a/mail-filter/rspamd/rspamd-9999.ebuild b/mail-filter/rspamd/rspamd-9999.ebuild
index 40d3b5290825..64cb537424f3 100644
--- a/mail-filter/rspamd/rspamd-9999.ebuild
+++ b/mail-filter/rspamd/rspamd-9999.ebuild
@@ -1,26 +1,20 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-if [[ ${PV} == *9999 ]] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vstakhov/rspamd.git"
-fi
-
-inherit cmake-utils pax-utils systemd user ${SCM}
-
-DESCRIPTION="Rapid spam filtering system"
-HOMEPAGE="https://github.com/vstakhov/rspamd"
+inherit cmake-utils pax-utils systemd tmpfiles user
if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
- KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/vstakhov/rspamd.git"
+ inherit git-r3
else
SRC_URI="https://github.com/vstakhov/rspamd/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
+DESCRIPTION="Rapid spam filtering system"
+HOMEPAGE="https://github.com/vstakhov/rspamd"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="cpu_flags_x86_ssse3 fann gd jemalloc +jit libressl pcre2 +torch"
@@ -32,7 +26,7 @@ RDEPEND="dev-db/sqlite:3
dev-libs/libevent:=
net-libs/libnsl
sys-apps/file
- <dev-util/ragel-7.0
+ dev-util/ragel
cpu_flags_x86_ssse3? ( dev-libs/hyperscan )
fann? ( sci-mathematics/fann )
gd? ( media-libs/gd[jpeg] )
@@ -49,6 +43,14 @@ pkg_setup() {
enewuser rspamd -1 -1 /var/lib/rspamd rspamd
}
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -i -e 's/User=_rspamd/User=rspamd/g' \
+ rspamd.service \
+ || die
+}
+
src_configure() {
local mycmakeargs=(
-DCONFDIR=/etc/rspamd
@@ -66,22 +68,31 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install
- newinitd "${FILESDIR}/rspamd.init-r5" rspamd
+
+ newconfd "${FILESDIR}"/rspamd.conf rspamd
+ newinitd "${FILESDIR}/rspamd-r6.init" rspamd
+ systemd_newunit rspamd.service rspamd.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
# Remove mprotect for JIT support
if use jit; then
- pax-mark m "${ED}"/usr/bin/rspamd-* "${ED}"/usr/bin/rspamadm-*
+ pax-mark m "${ED%/}"/usr/bin/rspamd-* "${ED%/}"/usr/bin/rspamadm-*
fi
- keepdir /var/lib/rspamd
- keepdir /var/log/rspamd
-
- fowners rspamd:rspamd /var/lib/rspamd /var/log/rspamd
-
insinto /etc/logrotate.d
- newins "${FILESDIR}/rspamd.logrotate" rspamd
+ newins "${FILESDIR}"/rspamd-r1.logrotate rspamd
- systemd_newunit rspamd.service rspamd.service
+ diropts -o rspamd -g rspamd
+ keepdir /var/{lib,log}/rspamd
+}
+
+pkg_postinst() {
+ tmpfiles_process "${PN}.conf"
}