summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/opendkim/opendkim-2.10.3-r26.ebuild (renamed from mail-filter/opendkim/opendkim-2.10.3-r25.ebuild)15
1 files changed, 15 insertions, 0 deletions
diff --git a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild b/mail-filter/opendkim/opendkim-2.10.3-r26.ebuild
index b105074a89ac..5aad117eed35 100644
--- a/mail-filter/opendkim/opendkim-2.10.3-r25.ebuild
+++ b/mail-filter/opendkim/opendkim-2.10.3-r26.ebuild
@@ -68,6 +68,15 @@ src_prepare() {
sed -e 's:dist_doc_DATA:dist_html_DATA:' \
-i libopendkim/docs/Makefile.am \
|| die
+
+ # The existing hard-coded path under /tmp is vulnerable to exploits
+ # since (for example) a user can create a symlink there to a file
+ # that portage will clobber. Reported upstream at,
+ #
+ # https://github.com/trusteddomainproject/OpenDKIM/issues/113
+ #
+ sed -e "s:/tmp:${T}:" -i libopendkim/tests/t-testdata.h || die
+
eautoreconf
}
@@ -121,6 +130,12 @@ src_compile() {
emake runstatedir=/run
}
+src_test() {
+ # Needed for now due to the expected sequencing of the setup/cleanup
+ # tests, https://github.com/trusteddomainproject/OpenDKIM/issues/110
+ emake -j1 check
+}
+
src_install() {
default
find "${D}" -name '*.la' -type f -delete || die