summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-menus')
-rw-r--r--mate-base/mate-menus/Manifest1
-rw-r--r--mate-base/mate-menus/mate-menus-1.8.0.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
index a1f70d68399e..0169283dbf80 100644
--- a/mate-base/mate-menus/Manifest
+++ b/mate-base/mate-menus/Manifest
@@ -1,2 +1 @@
DIST mate-menus-1.10.1.tar.xz 342516 SHA256 bd46d676bd4780f815d8343f8a8c3e67645c85fb812a943a0a69e664d3dcddbc SHA512 f0a96334c71052060d2f40b309b91a0a6464f8bd8135e43b29b3e9c67332b01205ffe1a3e2b262b910bbd0a679acd4ebd67b6de604c1e5cfb2bc42bf54028a86 WHIRLPOOL ae24e8bb2b99966e7676f535f6c9d0bfd32223d0dd9e9c5a371c40b15ce9b788cf9b0a7af7df1a2f5880b2fa03aa12fe45e43caaaba48450164c8bc23e47aa4a
-DIST mate-menus-1.8.0.tar.xz 342768 SHA256 0610c1c5c2348e8bcd1dae7bed808c451917a69b31d4b80de2b2f6288005b43c SHA512 724c0f4d98cabcc8d186e27024f116ba97ed4219ea563aecf14c22ef8d6b4dc1f5281ace2f836a5cfa32984e43cb3dd2b0ac1a9390dde9d477394c74a62348a0 WHIRLPOOL e5671a62f60eb8560a62e9f5e12267cd8cae34817a51a31afc58e26d3787ec7e9bdd2e17e81a3119892f2dc03df11004455d4c75247bef224428041003f3439b
diff --git a/mate-base/mate-menus/mate-menus-1.8.0.ebuild b/mate-base/mate-menus/mate-menus-1.8.0.ebuild
deleted file mode 100644
index 58d81766b8b1..000000000000
--- a/mate-base/mate-menus/mate-menus-1.8.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit gnome2 python-r1
-
-MATE_BRANCH="$(get_version_component_range 1-2)"
-
-SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://mate-desktop.org"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="debug +introspection python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/glib-2.15.2:2
- virtual/libintl:0
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40:*
- >=mate-base/mate-common-1.8:0
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-my_command() {
- if use python ; then
- python_foreach_impl run_in_build_dir $@
- else
- $@
- fi
-}
-
-src_configure() {
- G2CONF="${G2CONF} \
- $(use_enable python) \
- $(use_enable introspection)"
-
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- if ! use debug ; then
- G2CONF="${G2CONF} --enable-debug=minimum"
- fi
-
- if use python ; then
- python_copy_sources
- fi
-
- my_command gnome2_src_configure
-}
-
-src_compile() {
- my_command gnome2_src_compile
-}
-
-src_test() {
- my_command emake check
-}
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_install() {
- my_command gnome2_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}