summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 57ee6e82965a..4124e20b2efb 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,3 +1,4 @@
DIST mate-system-monitor-1.22.0.tar.xz 2190688 BLAKE2B 83ab7dfbc0033f094896c663790c1200e71a498d3a813a82c94593e6c6434942b2afd0fa1c3067452a46e0e1829a9239f1c145a315b9de2c2853c9f4f50618ef SHA512 6f97f934626b49320ea0dbb4e14743c4f33b12a85671b69465f689765f3003f00e51685b616e34a482c3ec0ca09ca4e13cbdb2e3eb4719c0d1fc7b25b24436a7
DIST mate-system-monitor-1.22.1.tar.xz 2202544 BLAKE2B 37eb2d265aedb259fd3f97aae64f76b7061eda6f4713137d4a9de9cdb078ce2176039c4a6cb7f9f63367c186df3bc181693b9526500f81fe0c9c52dc2e05e7a2 SHA512 ce5c514c333b85d6dd94b9fa212b51ed78212781da9719f730c50fc61fcf433e1a7df1d2665fe90e9529fba08207df59858b66f982bcd070845f62b22f8bd82f
DIST mate-system-monitor-1.22.2.tar.xz 2209852 BLAKE2B d5437596454e767cdbb32e7de062d5a9c6f55edce45f9439cfd555e9455f7cf935a4d15fcd8f19494feab1faae4e0ee07f469b6650d2da03372f9e2bea3ed8ac SHA512 47ccb38e27906c4de0cc18abc9d43ffc3b2c8f2f33b3f4cea3e47fd82c48870f03927fab39d323b61b9b871614b24bb2bc258d1c547650cdfb6b8eef65cb0de3
+DIST mate-system-monitor-1.24.0.tar.xz 2437396 BLAKE2B 78c8774ee1832772b2cda06bca051c91e10e882b841373e3f30575ab1d05cc2b799962d964be4cc8416f9747e44031e579410d9851bb82d6a13f6023f1a30b2a SHA512 430a2bf81f447143ba53cecb1c2659903cd957e313f6690adea363e9a8deccfd4ad64ebd8ce18dfb31a67fa7b51cbe087ffed7b5dcba5dd03b1010ec41b4d282
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
new file mode 100644
index 000000000000..467ce2fdfdfa
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="elogind systemd"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ myconf+=(
+ SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
+ SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}"
+}