summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/brlcad')
-rw-r--r--media-gfx/brlcad/Manifest1
-rw-r--r--media-gfx/brlcad/brlcad-7.18.4.ebuild100
-rw-r--r--media-gfx/brlcad/files/brlcad-7.18.4-libpng15.patch42
-rw-r--r--media-gfx/brlcad/metadata.xml34
4 files changed, 177 insertions, 0 deletions
diff --git a/media-gfx/brlcad/Manifest b/media-gfx/brlcad/Manifest
new file mode 100644
index 000000000000..7c9c4ed975d7
--- /dev/null
+++ b/media-gfx/brlcad/Manifest
@@ -0,0 +1 @@
+DIST brlcad-7.18.4.tar.gz 55406130 SHA256 90bd0c5afaa7a5c48846f6d4f4a59ae482c231b666e457ccf4ad7524236e928f
diff --git a/media-gfx/brlcad/brlcad-7.18.4.ebuild b/media-gfx/brlcad/brlcad-7.18.4.ebuild
new file mode 100644
index 000000000000..628b6cc1cd2d
--- /dev/null
+++ b/media-gfx/brlcad/brlcad-7.18.4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils java-pkg-opt-2 multilib
+
+DESCRIPTION="Constructive solid geometry modeling system"
+HOMEPAGE="http://brlcad.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmarks debug doc examples java opengl smp"
+
+RDEPEND="media-libs/libpng
+ sys-libs/zlib
+ >=sci-libs/tnt-3
+ sci-libs/jama
+ =dev-tcltk/itcl-3.4*
+ =dev-tcltk/itk-3.4*
+ dev-tcltk/iwidgets
+ dev-tcltk/tkimg
+ dev-tcltk/tkpng
+ sys-libs/libtermcap-compat
+ media-libs/urt
+ x11-libs/libXt
+ x11-libs/libXi
+ java? ( >=virtual/jre-1.5 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ java? ( >=virtual/jdk-1.5 )
+ doc? ( dev-libs/libxslt )"
+
+BRLCAD_DIR="${EPREFIX}/usr/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+
+ java-pkg-opt-2_src_prepare
+}
+
+src_configure() {
+ local myconf="--without-jdk"
+ use java && myconf="--with-jdk=$(java-config -O)"
+
+ econf \
+ --disable-strict-build \
+ --prefix="${BRLCAD_DIR}" \
+ --datadir="${BRLCAD_DIR}/share" \
+ --mandir="${BRLCAD_DIR}/man" \
+ --disable-almost-everything \
+ --disable-regex-build \
+ --disable-png-build \
+ --disable-zlib-build \
+ --disable-urt-build \
+ --disable-tcl-build \
+ --disable-tk-build \
+ --disable-itcl-build \
+ --disable-tkimg-build \
+ --disable-jove-build \
+ --disable-tnt-install \
+ --disable-iwidgets-install \
+ --enable-opennurbs-build \
+ --with-ldflags="-L${EPREFIX}/usr/$(get_libdir)/itcl3.4 -L${EPREFIX}/usr/$(get_libdir)/itk3.4" \
+ --with-x \
+ --with-x11 \
+ $(use_enable debug) \
+ $(use_enable debug optimization) \
+ $(use_enable debug runtime-debug) \
+ $(use_enable debug verbose) \
+ $(use_enable debug warnings) \
+ $(use_enable debug progress) \
+ $(use_enable doc documentation) \
+ $(use_enable examples models-install) \
+ $(use_enable smp parallel) \
+ $(use_with opengl ogl) \
+ ${myconf}
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ if use benchmarks; then
+ emake benchmark || die "emake benchmark failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/share/brlcad/{README,NEWS,AUTHORS,HACKING,INSTALL,COPYING}
+ dodoc AUTHORS NEWS README HACKING TODO BUGS ChangeLog
+ echo "PATH=\"${BRLCAD_DIR}/bin\"" > 99brlcad
+ echo "MANPATH=\"${BRLCAD_DIR}/man\"" >> 99brlcad
+ doenvd 99brlcad || die
+ newicon misc/macosx/Resources/ReadMe.rtfd/brlcad_logo_tiny.png brlcad.png
+ make_desktop_entry mged "BRL-CAD" brlcad "Graphics;Engineering"
+}
diff --git a/media-gfx/brlcad/files/brlcad-7.18.4-libpng15.patch b/media-gfx/brlcad/files/brlcad-7.18.4-libpng15.patch
new file mode 100644
index 000000000000..e0d42d1e22f9
--- /dev/null
+++ b/media-gfx/brlcad/files/brlcad-7.18.4-libpng15.patch
@@ -0,0 +1,42 @@
+http://bugs.gentoo.org/378273
+
+--- src/libged/png.c
++++ src/libged/png.c
+@@ -30,6 +30,8 @@
+ #include <string.h>
+ #include "bio.h"
+
++#include <zlib.h> /* Z_BEST_COMPRESSION */
++
+ #include "png.h"
+ #include "bu.h"
+ #include "vmath.h"
+--- src/fb/fb-png.c 2011-04-12 14:31:56.000000000 -0400
++++ src/fb/fb-png.c.new 2011-09-19 13:18:08.000000000 -0400
+@@ -38,13 +38,13 @@
+ # include <unistd.h>
+ #endif
+
++#include "zlib.h"
+ #include "png.h"
+ #include "bu.h"
+ #include "fb.h"
+
+ #include "pkg.h"
+
+-
+ /* in cmap-crunch.c */
+ extern void cmap_crunch(RGBpixel (*scan_buf), int pixel_ct, ColorMap *colormap);
+
+--- src/util/pix-png.c 2011-04-12 14:34:24.000000000 -0400
++++ src/util/pix-png.c.new 2011-09-19 13:18:59.000000000 -0400
+@@ -36,7 +36,8 @@
+ #include "bio.h"
+
+ #include "zlib.h"
+-#include "pngconf.h"
++/* removed as png.h includes this and including it in the wrong order seems to cause bugs
++#include "pngconf.h" */
+ #include "png.h"
+
+ #include "bu.h"
diff --git a/media-gfx/brlcad/metadata.xml b/media-gfx/brlcad/metadata.xml
new file mode 100644
index 000000000000..83f8886b3bf8
--- /dev/null
+++ b/media-gfx/brlcad/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>dongxuli2011@gmail.com</email>
+ <description>please assign bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ BRL-CAD is a Combinatorial/Constructive Solid Geometry (CSG)
+ solid modeling system that includes an interactive geometry editor,
+ ray-tracing support for rendering and geometric analysis,
+ network-distributed framebuffer support, image and signal-processing
+ tools, and an embedded scripting language.
+
+ The package is a collection of over 400 tools and utilities. Included
+ is support for various geometric data format conversions, image and
+ signal processing capabilities, ray-tracing based lighting models,
+ network distributed ray-tracing, parallel ray-tracing, animation
+ capabilities, data compression, image handling, and interactive 3-D
+ geometric editing, and also an implementation of Weiler's n-Manifold
+ Geometry (NMG) data structures for surface-based solid models and
+ photon mapping.
+</longdescription>
+ <use>
+ <flag name="benchmarks">
+ Run benchmarks during test phase (need test option enabled)
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">brlcad</remote-id>
+ </upstream>
+</pkgmetadata>