summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fotowall/fotowall-0.9-r2.ebuild')
-rw-r--r--media-gfx/fotowall/fotowall-0.9-r2.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/media-gfx/fotowall/fotowall-0.9-r2.ebuild b/media-gfx/fotowall/fotowall-0.9-r2.ebuild
index 6ca0264b26b8..2dcf28d10cf3 100644
--- a/media-gfx/fotowall/fotowall-0.9-r2.ebuild
+++ b/media-gfx/fotowall/fotowall-0.9-r2.ebuild
@@ -6,11 +6,9 @@ EAPI=6
inherit qmake-utils
-MY_P="${P/f/F}"
-
DESCRIPTION="Qt4 tool for creating wallpapers"
HOMEPAGE="http://www.enricoros.com/opensource/fotowall/"
-SRC_URI="https://fotowall.googlecode.com/files/${MY_P}.tar.bz2"
+SRC_URI="https://github.com/enricoros/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -27,8 +25,6 @@ DEPEND="${RDEPEND}
webcam? ( media-libs/libv4l )
"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
@@ -36,7 +32,7 @@ src_prepare() {
3rdparty/videocapture/VideoDevice.h || die
if ! use opengl; then
- sed -i "/QT += opengl/d" "${PN}.pro" || die "sed failed"
+ sed -i "/QT += opengl/d" ${PN}.pro || die
fi
}
@@ -50,6 +46,5 @@ src_configure() {
src_install() {
emake INSTALL_ROOT="${D}" install
-
dodoc README.markdown
}