summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gnuclad/gnuclad-0.2.4.ebuild')
-rw-r--r--media-gfx/gnuclad/gnuclad-0.2.4.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/media-gfx/gnuclad/gnuclad-0.2.4.ebuild b/media-gfx/gnuclad/gnuclad-0.2.4.ebuild
index 77b5f29236f9..9d9826b28d99 100644
--- a/media-gfx/gnuclad/gnuclad-0.2.4.ebuild
+++ b/media-gfx/gnuclad/gnuclad-0.2.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Cladogram tree generator mainly used by the GNU/Linux distro timeline project"
HOMEPAGE="https://launchpad.net/gnuclad/"
SRC_URI="http://launchpad.net/gnuclad/trunk/0.2/+download/${P}.tar.gz"
@@ -15,6 +17,15 @@ IUSE="examples"
DEPEND=""
RDEPEND=""
+PATCHES=(
+ "${FILESDIR}/${P}"-werror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_install() {
default