summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch')
-rw-r--r--media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch b/media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch
new file mode 100644
index 000000000000..b68e618cc018
--- /dev/null
+++ b/media-gfx/gphoto2/files/gphoto2-2.5.26-s-cdk-cdk.h-cdk.h.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/679332
+
+diff --git a/configure.ac b/configure.ac
+index ed76a66..b0db85c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_ARG_WITH([cdk-prefix],AS_HELP_STRING([--with-cdk-prefix=PREFIX],
+ if $try_cdk; then
+ CPPFLAGS_save="$CPPFLAGS"
+ CPPFLAGS="-I$cdk_prefix/include $CPPFLAGS"
+- AC_CHECK_HEADER([cdk/cdk.h], [
++ AC_CHECK_HEADER([cdk.h], [
+ have_cdk=:
+ AC_PATH_PROG([CDK_CONFIG], [cdk5-config])
+ if test -n "${CDK_CONFIG}"; then
+diff --git a/gphoto2/gphoto2-cmd-config.c b/gphoto2/gphoto2-cmd-config.c
+index 360fd61..c801604 100644
+--- a/gphoto2/gphoto2-cmd-config.c
++++ b/gphoto2/gphoto2-cmd-config.c
+@@ -29,7 +29,7 @@
+
+ #include <gphoto2/gphoto2-widget.h>
+
+-#include <cdk/cdk.h>
++#include <cdk.h>
+
+ #ifndef MAX
+ # define MAX(a, b) ((a) > (b) ? (a) : (b))
+--