summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/hugin/hugin-2018.0.0.ebuild')
-rw-r--r--media-gfx/hugin/hugin-2018.0.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/media-gfx/hugin/hugin-2018.0.0.ebuild b/media-gfx/hugin/hugin-2018.0.0.ebuild
index 3b5e82f438dd..cb72199b0eb0 100644
--- a/media-gfx/hugin/hugin-2018.0.0.ebuild
+++ b/media-gfx/hugin/hugin-2018.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
WX_GTK_VER="3.0"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit python-single-r1 wxwidgets versionator cmake-utils
+inherit python-single-r1 wxwidgets cmake-utils eapi7-ver
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -55,7 +55,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DOCS=( authors.txt README TODO )
-S=${WORKDIR}/${PN}-$(get_version_component_range 1-2).0
+PATCHES=( "${FILESDIR}/${P}-exiv2-0.27.patch" )
+
+S=${WORKDIR}/${PN}-$(ver_cut 1-2).0
pkg_setup() {
use python && python-single-r1_pkg_setup