summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/imagemagick/files/imagemagick-6.9.1.7-cflags.patch')
-rw-r--r--media-gfx/imagemagick/files/imagemagick-6.9.1.7-cflags.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/imagemagick/files/imagemagick-6.9.1.7-cflags.patch b/media-gfx/imagemagick/files/imagemagick-6.9.1.7-cflags.patch
new file mode 100644
index 000000000000..53609c0a61d8
--- /dev/null
+++ b/media-gfx/imagemagick/files/imagemagick-6.9.1.7-cflags.patch
@@ -0,0 +1,68 @@
+https://github.com/ImageMagick/ImageMagick/issues/15
+
+--- ImageMagick-6.9.1-7/configure
++++ ImageMagick-6.9.1-7/configure
+@@ -35563,30 +35563,6 @@
+ fi
+
+
+-#
+-# Sanitize output variables (asthetic).
+-#
+-for variable in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS PCFLAGS X_CFLAGS; do
+- sanitize=''
+- eval value=$`echo $variable`
+- for component in $value
+- do
+- unique=yes
+- for test_component in $sanitize
+- do
+- if test $component = $test_component; then
+- unique=no
+- break
+- fi
+- done
+- if test $unique = yes; then
+- sanitize="$sanitize $component"
+- fi
+- done
+- sanitize=`echo $sanitize | sed -e 's/^ *//g'`
+- eval ${variable}=\${sanitize}
+-done
+-
+ # Pass only user-provided LIBS as "global" libraries
+ LIBS=$USER_LIBS
+
+--- ImageMagick-6.9.1-7/configure.ac
++++ ImageMagick-6.9.1-7/configure.ac
+@@ -3706,30 +3706,6 @@
+ fi
+ AC_SUBST(MAGICK_DEP_LIBS)
+
+-#
+-# Sanitize output variables (asthetic).
+-#
+-for variable in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS PCFLAGS X_CFLAGS; do
+- sanitize=''
+- eval value=$`echo $variable`
+- for component in $value
+- do
+- unique=yes
+- for test_component in $sanitize
+- do
+- if test $component = $test_component; then
+- unique=no
+- break
+- fi
+- done
+- if test $unique = yes; then
+- sanitize="$sanitize $component"
+- fi
+- done
+- sanitize=`echo $sanitize | sed -e 's/^ *//g'`
+- eval ${variable}=\${sanitize}
+-done
+-
+ # Pass only user-provided LIBS as "global" libraries
+ LIBS=$USER_LIBS
+