summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/plantuml/plantuml-0.8046.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-0.8046.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/media-gfx/plantuml/plantuml-0.8046.ebuild b/media-gfx/plantuml/plantuml-0.8046.ebuild
deleted file mode 100644
index 0db55ffddc12..000000000000
--- a/media-gfx/plantuml/plantuml-0.8046.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="source"
-inherit java-pkg-2 java-ant-2
-
-MY_VER=$(ver_cut 2)
-DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
-HOMEPAGE="http://plantuml.com"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_VER}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-DEPEND=">=virtual/jdk-1.7"
-
-RDEPEND=">=virtual/jre-1.7
- dev-java/ant-core:0
- >=media-gfx/graphviz-2.26.3"
-
-S="${WORKDIR}/${PN}-${MY_VER}"
-
-EANT_BUILD_TARGET="dist"
-EANT_GENTOO_CLASSPATH="ant-core"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-src_install() {
- java-pkg_dojar ${PN}.jar
- java-pkg_dolauncher ${PN} --jar ${PN}.jar
- use source && java-pkg_dosrc src/*
-}