summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngcheck/pngcheck-2.3.0.ebuild')
-rw-r--r--media-gfx/pngcheck/pngcheck-2.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/pngcheck-2.3.0.ebuild b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
new file mode 100644
index 000000000000..7293de435f26
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-2.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="verifies the integrity of PNG, JNG and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ CFLAGS="${LDFLAGS} ${CFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz" || die
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize} || die
+ dodoc CHANGELOG README
+}