summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sam2p/files')
-rw-r--r--media-gfx/sam2p/files/sam2p-0.45-cflags.patch37
-rw-r--r--media-gfx/sam2p/files/sam2p-0.45-fbsd.patch14
-rw-r--r--media-gfx/sam2p/files/sam2p-0.45-nostrip.patch13
-rw-r--r--media-gfx/sam2p/files/sam2p-0.49-glibc-2.20.patch18
-rw-r--r--media-gfx/sam2p/files/sam2p-0.49.1-build.patch42
-rw-r--r--media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch39
6 files changed, 163 insertions, 0 deletions
diff --git a/media-gfx/sam2p/files/sam2p-0.45-cflags.patch b/media-gfx/sam2p/files/sam2p-0.45-cflags.patch
new file mode 100644
index 000000000000..d6636d5308cf
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.45-cflags.patch
@@ -0,0 +1,37 @@
+Index: sam2p-0.45/configure.in
+===================================================================
+--- sam2p-0.45.orig/configure.in
++++ sam2p-0.45/configure.in
+@@ -81,7 +81,7 @@ fi
+ dnl Checks for programs.
+ dnl AC_PROG_CC
+ AC_LANG_CPLUSPLUS
+-CXXFLAGS=" "
++#CXXFLAGS=" "
+ dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
+ CCC="$CCC g++"
+ dnl ^^^ check g++ before c++ (see acspecific.m4, grep AC_PROG_CXX)
+@@ -215,7 +215,7 @@ AC_OUTPUT(Makehelp)
+
+ dnl AC_PTS_RUN_OK([perl -x -S ./ccdep.pl $CXX], [], [AC_MSG_ERROR(cannot compute depends)])
+ rm -f Makedep
+-AC_PTS_RUN_OK([make Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
++AC_PTS_RUN_OK([gmake Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
+ AC_PTS_OK
+ echo "configure done. Now you should run: make; make install"
+
+Index: sam2p-0.45/Makefile
+===================================================================
+--- sam2p-0.45.orig/Makefile
++++ sam2p-0.45/Makefile
+@@ -49,8 +49,8 @@ IDE_MODES := release debug
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX)
++CXD_no =$(CXX) -DNDEBUG
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)
diff --git a/media-gfx/sam2p/files/sam2p-0.45-fbsd.patch b/media-gfx/sam2p/files/sam2p-0.45-fbsd.patch
new file mode 100644
index 000000000000..aed13acf08dd
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.45-fbsd.patch
@@ -0,0 +1,14 @@
+--- gensio.cpp.orig Fri Feb 7 02:24:56 2003
++++ gensio.cpp Fri Feb 7 02:25:11 2003
+@@ -491,11 +491,7 @@
+ /* --- */
+
+
+-#if HAVE_lstat_in_sys_stat
+-# define PTS_lstat lstat
+-#else
+ # define PTS_lstat stat
+-#endif
+
+ /** @param fname must start with '/' (dir separator)
+ * @return true if file successfully created
diff --git a/media-gfx/sam2p/files/sam2p-0.45-nostrip.patch b/media-gfx/sam2p/files/sam2p-0.45-nostrip.patch
new file mode 100644
index 000000000000..d60a77c36207
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.45-nostrip.patch
@@ -0,0 +1,13 @@
+Index: sam2p-0.45/Makefile
+===================================================================
+--- sam2p-0.45.orig/Makefile
++++ sam2p-0.45/Makefile
+@@ -17,7 +17,7 @@ PERL_BADLANG=x
+ export PERL_BADLANG
+
+ CXXX=$(CXD_assert)
+-LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
++LDALL=$(LDXX) $(LDFLAGS) $(LIBS)
+ ifeq ($(ENABLE_DEBUG), no)
+ CXXX=$(CXD_no)
+ endif
diff --git a/media-gfx/sam2p/files/sam2p-0.49-glibc-2.20.patch b/media-gfx/sam2p/files/sam2p-0.49-glibc-2.20.patch
new file mode 100644
index 000000000000..f96a97969390
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.49-glibc-2.20.patch
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/524048
+
+ignore warnings w/newer glibc-2.20
+
+patch by Dmitry Derevyanko
+
+--- a/ccdep.pl
++++ b/ccdep.pl
+@@ -233,6 +233,9 @@
+ } elsif ($S=~/\A([^:]+):\d+:(\d+:)? warning: this is the location of /) {
+ # ^^^ gcc-3.1
+ undef $included_from;
++ } elsif ($S=~/\A([^:]+):\d+:(\d+:)? warning: .*\bdeprecated\b/) {
++ # Example: /usr/include/features.h:148:3: warning: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Wcpp]
++ undef $included_from;
+ } elsif ($S=~/: No such file or directory$/) { # Depends on $ENV{LC_ALL}.
+ # ^^^ gcc-3.3
+ undef $included_from;
diff --git a/media-gfx/sam2p/files/sam2p-0.49.1-build.patch b/media-gfx/sam2p/files/sam2p-0.49.1-build.patch
new file mode 100644
index 000000000000..ba421463d536
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.49.1-build.patch
@@ -0,0 +1,42 @@
+--- configure.in
++++ configure.in
+@@ -81,7 +81,7 @@
+ dnl Checks for programs.
+ dnl AC_PROG_CC
+ AC_LANG_CPLUSPLUS
+-CXXFLAGS=" "
++#CXXFLAGS=" "
+ dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
+ CCC="$CCC g++"
+ dnl ^^^ check g++ before c++ (see acspecific.m4, grep AC_PROG_CXX)
+@@ -215,7 +215,7 @@
+
+ dnl AC_PTS_RUN_OK([perl -x -S ./ccdep.pl $CXX], [], [AC_MSG_ERROR(cannot compute depends)])
+ rm -f Makedep
+-AC_PTS_RUN_OK([make Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
++AC_PTS_RUN_OK([gmake Makedep], [], [AC_MSG_ERROR(cannot compute depends)])
+ AC_PTS_OK
+ echo "configure done. Now you should run: make; make install"
+
+--- Makefile
++++ Makefile
+@@ -17,7 +17,7 @@
+ export PERL_BADLANG
+
+ CXXX=$(CXD_assert)
+-LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
++LDALL=$(LDXX) $(LDFLAGS) $(LIBS)
+ ifeq ($(ENABLE_DEBUG), no)
+ CXXX=$(CXD_no)
+ endif
+@@ -51,8 +51,8 @@
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX)
++CXD_no =$(CXX) -DNDEBUG
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)
diff --git a/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch b/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch
new file mode 100644
index 000000000000..d427c2076d3c
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch
@@ -0,0 +1,39 @@
+Index: ccdep.pl
+===================================================================
+--- ccdep.pl (revision 123)
++++ ccdep.pl (revision 125)
+@@ -137,13 +137,20 @@
+
+ my @DS=find_ds();
+ my @DSQ=map{shq$_}@DS;
+-my $R="$GCCP -DOBJDEP -M -MG -E 2>&1 @DSQ";
+-$R=backtick($R);
++my $DIAG=" -fno-diagnostics-show-caret";
++my $Q="$GCCP -DOBJDEP$DIAG -M -MG -E 2>&1 @DSQ";
++my $R=backtick($Q);
++if ($R=~/\berror: .*-fno-diagnostics-show-caret\b/) {
++ # gcc-4.6 and earlier don't have this flag, and they fail.
++ $Q=~s@ -fno-diagnostics-show-caret(?=\s)@@;
++ $DIAG="";
++ $R=backtick($Q);
++}
+
+ if ($R!~/: warning: #warning\b/) {
+ # config2.h:314:4: warning: #warning REQUIRES: c_lgcc3.o
+ # Dat: g++-3.3 ignores #warning with -M -MG -E
+- $R.="\n".backtick("$GCCP -DOBJDEP -E 2>&1 >/dev/null @DSQ");
++ $R.="\n".backtick("$GCCP -DOBJDEP$DIAG -E 2>&1 >/dev/null @DSQ");
+ }
+
+ ## die $R;
+--- rule.hpp 2013-04-18 12:14:20.385333527 +0200
++++ rule.hpp 2013-04-18 12:14:35.818870070 +0200
+@@ -88,7 +88,7 @@
+ PR_PNGAuto=15,
+ PR_PNGAutoMaybe=25,
+ PR_PNGAutoBadUnsigned=45,
+- PR_PNGAutoBadSigned=55,
++ PR_PNGAutoBadSigned=55
+ END_STATIC_ENUM()
+ pr_t Predictor;
+