summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/ufraw')
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch20
-rw-r--r--media-gfx/ufraw/ufraw-0.22-r1.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch b/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
new file mode 100644
index 000000000000..a5397260ffb5
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-fix-unsigned-char.patch
@@ -0,0 +1,20 @@
+Description: Fix unsigned char declaration of src[]
+Author: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
+Last-Update: 2017-02-27
+
+https://bugs.gentoo.org/show_bug.cgi?id=622484
+https://sourceforge.net/p/ufraw/bugs/417/
+https://src.fedoraproject.org/cgit/rpms/ufraw.git/tree/05_fix_build_due_to_unsigned_char.patch
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=856227
+
+--- ufraw-0.22.orig/dcraw.cc
++++ ufraw-0.22/dcraw.cc
+@@ -2285,7 +2285,7 @@ void CLASS quicktake_100_load_raw()
+
+ void CLASS kodak_radc_load_raw()
+ {
+- static const char src[] = {
++ static const signed char src[] = {
+ 1,1, 2,3, 3,4, 4,2, 5,7, 6,5, 7,6, 7,8,
+ 1,0, 2,1, 3,3, 4,4, 5,2, 6,7, 7,6, 8,5, 8,8,
+ 2,1, 2,3, 3,0, 3,2, 3,4, 4,6, 5,5, 6,7, 6,8,
diff --git a/media-gfx/ufraw/ufraw-0.22-r1.ebuild b/media-gfx/ufraw/ufraw-0.22-r1.ebuild
index 155af1ce1709..e8bb0325f6cc 100644
--- a/media-gfx/ufraw/ufraw-0.22-r1.ebuild
+++ b/media-gfx/ufraw/ufraw-0.22-r1.ebuild
@@ -41,6 +41,7 @@ PATCHES=(
"${FILESDIR}"/${P}-jasper-automagic.patch
"${FILESDIR}"/${P}-crashfix.patch
"${FILESDIR}"/${P}-drop_superfluous_abs.patch
+ "${FILESDIR}"/${P}-fix-unsigned-char.patch
)
src_prepare() {