summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/edje/edje-1.7.9.ebuild')
-rw-r--r--media-libs/edje/edje-1.7.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/edje/edje-1.7.9.ebuild b/media-libs/edje/edje-1.7.9.ebuild
new file mode 100644
index 000000000000..a53d49da09cd
--- /dev/null
+++ b/media-libs/edje/edje-1.7.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit enlightenment
+
+DESCRIPTION="graphical layout and animation library"
+HOMEPAGE="http://www.enlightenment.org/pages/edje.html"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug +cache static-libs vim-syntax"
+
+DEPEND="dev-lang/lua
+ >=dev-libs/eet-1.7.9
+ >=dev-libs/eina-1.7.9
+ >=dev-libs/embryo-1.7.9
+ >=media-libs/evas-1.7.9
+ >=dev-libs/ecore-1.7.9"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ MY_ECONF+="
+ $(use_enable cache edje-program-cache)
+ $(use_enable cache edje-calc-cache)
+ $(use_enable !debug amalgamation)
+ $(use_enable doc)
+ $(use_with vim-syntax vim /usr/share/vim)
+ "
+ enlightenment_src_configure
+}
+
+src_install() {
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins data/edc.vim || die
+ fi
+ dodoc utils/{gimp-edje-export.py,inkscape2edc} || die
+ enlightenment_src_install
+}