summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/ffmpegsource/ffmpegsource-2.20.ebuild')
-rw-r--r--media-libs/ffmpegsource/ffmpegsource-2.20.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/ffmpegsource/ffmpegsource-2.20.ebuild b/media-libs/ffmpegsource/ffmpegsource-2.20.ebuild
new file mode 100644
index 000000000000..0f3d877e9a98
--- /dev/null
+++ b/media-libs/ffmpegsource/ffmpegsource-2.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
+HOMEPAGE="https://github.com/FFMS/ffms2"
+SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 x86"
+IUSE="libav static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ libav? ( >=media-video/libav-9.17:0= )
+ !libav? ( >=media-video/ffmpeg-1.2.6-r1:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}/ffms2-${PV}"