summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/gegl-0.2.0-r4.ebuild30
-rw-r--r--media-libs/gegl/gegl-0.2.0-r5.ebuild33
-rw-r--r--media-libs/gegl/gegl-0.3.20.ebuild6
-rw-r--r--media-libs/gegl/gegl-0.3.24.ebuild6
-rw-r--r--media-libs/gegl/gegl-0.3.26.ebuild6
-rw-r--r--media-libs/gegl/gegl-0.3.28.ebuild6
-rw-r--r--media-libs/gegl/gegl-0.3.30.ebuild6
-rw-r--r--media-libs/gegl/gegl-0.3.8.ebuild9
8 files changed, 59 insertions, 43 deletions
diff --git a/media-libs/gegl/gegl-0.2.0-r4.ebuild b/media-libs/gegl/gegl-0.2.0-r4.ebuild
index ddb70a4e401d..2268786841ab 100644
--- a/media-libs/gegl/gegl-0.2.0-r4.ebuild
+++ b/media-libs/gegl/gegl-0.2.0-r4.ebuild
@@ -54,15 +54,26 @@ DEPEND="${RDEPEND}
DOCS=( ChangeLog INSTALL README NEWS )
-src_prepare() {
+PATCHES=(
# https://bugs.gentoo.org/show_bug.cgi?id=442016
- epatch "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
- epatch "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
+ "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
+ "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
# https://bugs.gentoo.org/show_bug.cgi?id=416587
- epatch "${FILESDIR}/${P}-introspection-version.patch"
+ "${FILESDIR}/${P}-introspection-version.patch"
+
+ "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+ "${FILESDIR}"/${P}-g_log_domain.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=605216
+ # https://bugs.gentoo.org/show_bug.cgi?id=617430
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-libopenraw-0.1.patch # bug 639834
+ "${FILESDIR}"/${P}-fix-without-exiv2.patch # bug 641872
+)
- epatch "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+src_prepare() {
+ default
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
# don't require Apple's OpenCL on versions of OSX that don't have it
@@ -70,15 +81,6 @@ src_prepare() {
sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
fi
- epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
- # https://bugs.gentoo.org/show_bug.cgi?id=605216
- # https://bugs.gentoo.org/show_bug.cgi?id=617430
- epatch "${FILESDIR}"/${P}-underlinking.patch
- epatch "${FILESDIR}"/${P}-libopenraw-0.1.patch # bug 639834
- epatch "${FILESDIR}"/${P}-fix-without-exiv2.patch # bug 641872
-
- eapply_user
eautoreconf
# https://bugs.gentoo.org/show_bug.cgi?id=468248
diff --git a/media-libs/gegl/gegl-0.2.0-r5.ebuild b/media-libs/gegl/gegl-0.2.0-r5.ebuild
index 717ad1841b63..cd6b1554809a 100644
--- a/media-libs/gegl/gegl-0.2.0-r5.ebuild
+++ b/media-libs/gegl/gegl-0.2.0-r5.ebuild
@@ -54,18 +54,30 @@ DEPEND="${RDEPEND}
DOCS=( ChangeLog INSTALL README NEWS )
-src_prepare() {
+PATCHES=(
# https://bugs.gentoo.org/show_bug.cgi?id=636780
- epatch "${FILESDIR}/${P}-ffmpeg-av_frame_alloc.patch"
+ "${FILESDIR}/${P}-ffmpeg-av_frame_alloc.patch"
# https://bugs.gentoo.org/show_bug.cgi?id=442016
- epatch "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
- epatch "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
+ "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
+ "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
# https://bugs.gentoo.org/show_bug.cgi?id=416587
- epatch "${FILESDIR}/${P}-introspection-version.patch"
+ "${FILESDIR}/${P}-introspection-version.patch"
+
+ "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+ "${FILESDIR}"/${P}-g_log_domain.patch
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=605216
+ # https://bugs.gentoo.org/show_bug.cgi?id=617430
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-libopenraw-0.1.patch # bug 639834
+ "${FILESDIR}"/${P}-fix-without-exiv2.patch # bug 641872
+
+)
- epatch "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+src_prepare() {
+ default
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
# don't require Apple's OpenCL on versions of OSX that don't have it
@@ -73,15 +85,6 @@ src_prepare() {
sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
fi
- epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
- # https://bugs.gentoo.org/show_bug.cgi?id=605216
- # https://bugs.gentoo.org/show_bug.cgi?id=617430
- epatch "${FILESDIR}"/${P}-underlinking.patch
- epatch "${FILESDIR}"/${P}-libopenraw-0.1.patch # bug 639834
- epatch "${FILESDIR}"/${P}-fix-without-exiv2.patch # bug 641872
-
- eapply_user
eautoreconf
# https://bugs.gentoo.org/show_bug.cgi?id=468248
diff --git a/media-libs/gegl/gegl-0.3.20.ebuild b/media-libs/gegl/gegl-0.3.20.ebuild
index 6afa0cc4600d..ca8af3a92928 100644
--- a/media-libs/gegl/gegl-0.3.20.ebuild
+++ b/media-libs/gegl/gegl-0.3.20.ebuild
@@ -75,6 +75,10 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -91,8 +95,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset
diff --git a/media-libs/gegl/gegl-0.3.24.ebuild b/media-libs/gegl/gegl-0.3.24.ebuild
index 4dc1c3610076..725be5c3b377 100644
--- a/media-libs/gegl/gegl-0.3.24.ebuild
+++ b/media-libs/gegl/gegl-0.3.24.ebuild
@@ -75,6 +75,10 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -91,8 +95,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset
diff --git a/media-libs/gegl/gegl-0.3.26.ebuild b/media-libs/gegl/gegl-0.3.26.ebuild
index 7aa01eab364d..aaf6fcd179ba 100644
--- a/media-libs/gegl/gegl-0.3.26.ebuild
+++ b/media-libs/gegl/gegl-0.3.26.ebuild
@@ -75,6 +75,10 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -91,8 +95,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset
diff --git a/media-libs/gegl/gegl-0.3.28.ebuild b/media-libs/gegl/gegl-0.3.28.ebuild
index 863f2e51ff1d..7ca15acd39e0 100644
--- a/media-libs/gegl/gegl-0.3.28.ebuild
+++ b/media-libs/gegl/gegl-0.3.28.ebuild
@@ -75,6 +75,10 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -91,8 +95,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset
diff --git a/media-libs/gegl/gegl-0.3.30.ebuild b/media-libs/gegl/gegl-0.3.30.ebuild
index 7ea4b3acef94..6ca6a617b173 100644
--- a/media-libs/gegl/gegl-0.3.30.ebuild
+++ b/media-libs/gegl/gegl-0.3.30.ebuild
@@ -75,6 +75,10 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -91,8 +95,6 @@ src_prepare() {
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset
diff --git a/media-libs/gegl/gegl-0.3.8.ebuild b/media-libs/gegl/gegl-0.3.8.ebuild
index 92e02f5f4eb8..519fc7305637 100644
--- a/media-libs/gegl/gegl-0.3.8.ebuild
+++ b/media-libs/gegl/gegl-0.3.8.ebuild
@@ -75,6 +75,11 @@ pkg_setup() {
use test && use introspection && python-any-r1_pkg_setup
}
+PATCHES=(
+ #"${FILESDIR}"/${P}-g_log_domain.patch
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
src_prepare() {
default
@@ -86,15 +91,11 @@ src_prepare() {
sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
fi
- #epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
# commit 7c78497b : tests that use gegl.png are broken on non-amd64
sed -e '/clones.xml/d' \
-e '/composite-transform.xml/d' \
-i tests/compositions/Makefile.am || die
- epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
eautoreconf
gnome2_environment_reset