summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index e947067639be..7861d05551db 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-good-0.10.31.tar.xz 2738016 SHA256 77a8436a7c0a15f876bad2961683
DIST gst-plugins-good-1.2.3.tar.xz 2878780 SHA256 bfb33536a515bdcc34482f64b8d9cc3e47c753878b254923b419bc2f7485e470 SHA512 74203578c92c6979b76e6070fd976989b7b81d3fec4317037d04391cab8142738d7b443915bced1c77e97137ebd47728ef570a55b758a946fb5bc06b7c67b407 WHIRLPOOL 0b5a66751d6e966f4df7455b9227a8da07716a9111cf74bab75e0f3c0efdc8e1e872bb5b220a5ae1edf870c00f5677451f61fb198c709e51bb3f055ebf27669d
DIST gst-plugins-good-1.2.4.tar.xz 2882188 SHA256 c9c90368393c2e5e78387e95c02ce7b19f48e793bba6d8547f2c4b51c6f420d3 SHA512 2c057062e10b5ff4cc63d54ffd2a8fb013f264584a175fdadc2fa0b02a7bc390bde0747e7888c6bed45713ce62cd0b6da7d255c99ce5171e9e5c41d6aac90086 WHIRLPOOL 43b4fefa94cfe85e3082fcaaa70fc159381a3d43c43bc15e8bc92b9fe0412bfdba56107c1b2334c632fecdf9b78c8334d962a49efb29a4e82a487a9121bbea33
DIST gst-plugins-good-1.4.5.tar.xz 3031588 SHA256 79b1b5f3f7bcaa8a615202eb5e176121eeb8336960f70687e536ad78dbc7e641 SHA512 0cf880af21956138e127508f6020fdc10f6ed01b765b0d3364d038c8e104947486c83c157c7b957193b82d59f724e342a6d12900b6a97abe6e2f3dac65d71be0 WHIRLPOOL a56ca2c2f2b73f299cb3c3605eb70ddbd97d9513d26ee11d91608c08589149df97f23490a6513d991c6b552a7b8a71f75463fd6dbf7579943ac859254eb0af3c
+DIST gst-plugins-good-1.6.0.tar.xz 3176568 SHA256 a0915639595305e48884656e22b16fda7c6892aa02cdb3eb43e23dab6e6b81fa SHA512 100b1f47d1c575e1f21fa4796153464cb65b75dd930be707a75c602dd90745a7b0742f64bba2f8210a7f3561774e4f9f81ce04f42a31e0e1def18292ca9d6706 WHIRLPOOL b1ce02c26b80dee2835fa06ac4ce1c506055a149906931eba8a228017217fef3f450c6a59aa05e9c1dc3287382ac4a67118921ed0f08e31da1d565b86fe0f7c9
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild
new file mode 100644
index 000000000000..637d812b0ffd
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+# dtmf plugin moved from bad to good in 1.2
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-bad-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ # https://bugs.gentoo.org/show_bug.cgi?id=22249
+ filter-flags "-fprefetch-loop-arrays"
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}