summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsbsms')
-rw-r--r--media-libs/libsbsms/Manifest3
-rw-r--r--media-libs/libsbsms/files/libsbsms-2.0.0-cflags.patch24
-rw-r--r--media-libs/libsbsms/files/libsbsms-2.0.1-includes.patch11
-rw-r--r--media-libs/libsbsms/files/libsbsms-2.0.2-cflags.patch24
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.0.ebuild35
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.1.ebuild37
-rw-r--r--media-libs/libsbsms/libsbsms-2.0.2.ebuild35
-rw-r--r--media-libs/libsbsms/metadata.xml8
8 files changed, 177 insertions, 0 deletions
diff --git a/media-libs/libsbsms/Manifest b/media-libs/libsbsms/Manifest
new file mode 100644
index 000000000000..2a6b1c88ffe6
--- /dev/null
+++ b/media-libs/libsbsms/Manifest
@@ -0,0 +1,3 @@
+DIST libsbsms-2.0.0.tar.gz 832881 SHA256 960c7bf4bd0f5024f96be6ff8891118bd5d029f55525d1a43d8d01c8430c88d9 SHA512 c3047310c5e5080eb437f426ac679fda3cd18ccf06e287667701aa9ef50e47285df4cc29e5d1dd82e9bdd1e668bf33ee437d9bc8499ba1687b172ac904d80d92 WHIRLPOOL ae519fc74e9145a309c0fcdf7eb84335fb8c0b4d5ea5863ab14fe447dc8100fa7cb98c3dbd8ddbb0ddc07b609404f49405f2d96e7c68d1e8f98bcbfc9563da5a
+DIST libsbsms-2.0.1.tar.gz 741474 SHA256 1012201f3d982960ca29142e3adab79f3668932b23cc38a9f9088ca9a2588b25 SHA512 62d5b3bc58069d697f0cf9505f2da22555a1fa8c966191cdd369161d56266069ae47a41100103439dc58b7dd01bbc3b11279400a2d0c161b2b4b9c854199ae45 WHIRLPOOL a01fa860088e4b386184f36ddc8c19522ce5f850f76cebf8f2800aa6f21715112fc03457653842b581b4cb16c7d064a9f2babe54149ca4c652a497ea31fdce93
+DIST libsbsms-2.0.2.tar.gz 450170 SHA256 ceab3d970664b337057b46bcf55283d50d329da636bf83d0ee7c36e22341aeee SHA512 8aaab3e191f3e10e559683ab4ebdcb8d951cf0e776390234f25675a98640d60d20aed872061ba72fdc3bd7827b7d46bc27225fe947cdd7fa4312f75cbdd78e6c WHIRLPOOL 4cf6c0564a1e270ad46b90f07e1ab36c642384994ad1224c0f4c56dfdeafa5afbaadecbf8151a9767a39203e661443964b823b21c45d3a7b29fcf121cb7910e6
diff --git a/media-libs/libsbsms/files/libsbsms-2.0.0-cflags.patch b/media-libs/libsbsms/files/libsbsms-2.0.0-cflags.patch
new file mode 100644
index 000000000000..63de676beb66
--- /dev/null
+++ b/media-libs/libsbsms/files/libsbsms-2.0.0-cflags.patch
@@ -0,0 +1,24 @@
+--- libsbsms-2.0.0/configure.in
++++ libsbsms-2.0.0/configure.in
+@@ -69,8 +69,6 @@
+
+ AC_ARG_ENABLE(universal_binary,[ --enable-universal_binary enable universal binary build: (default: disable)],[enable_universal_binary=$enableval],[enable_universal_binary=no])
+
+-SBSMS_CFLAGS="-ffast-math -funroll-loops"
+-
+ if test x$enable_static = xno; then
+ case "$target_os" in
+ darwin*)
+@@ -81,12 +79,6 @@
+ esac
+ fi
+
+-if test x$enable_debug = xyes; then
+- SBSMS_CFLAGS="$SBSMS_CFLAGS -g -O3"
+-else
+- SBSMS_CFLAGS="$SBSMS_CFLAGS -O3 -fomit-frame-pointer"
+-fi
+-
+ if test x$enable_multithreaded = xyes; then
+ AC_DEFINE(MULTITHREADED,1,[Define to compile multithreaded sbsms])
+ fi
diff --git a/media-libs/libsbsms/files/libsbsms-2.0.1-includes.patch b/media-libs/libsbsms/files/libsbsms-2.0.1-includes.patch
new file mode 100644
index 000000000000..63937fa6157d
--- /dev/null
+++ b/media-libs/libsbsms/files/libsbsms-2.0.1-includes.patch
@@ -0,0 +1,11 @@
+diff -urN libsbsms-2.0.1.old/src/buffer.h libsbsms-2.0.1/src/buffer.h
+--- libsbsms-2.0.1.old/src/buffer.h 2012-12-08 18:43:46.772667486 +0100
++++ libsbsms-2.0.1/src/buffer.h 2012-12-08 18:44:04.677668212 +0100
+@@ -2,6 +2,7 @@
+ #ifndef BUFFER_H
+ #define BUFFER_H
+
++#include <stdlib.h>
+ #include "sbsms.h"
+ #include "grain.h"
+ #include <list>
diff --git a/media-libs/libsbsms/files/libsbsms-2.0.2-cflags.patch b/media-libs/libsbsms/files/libsbsms-2.0.2-cflags.patch
new file mode 100644
index 000000000000..929135baa0ec
--- /dev/null
+++ b/media-libs/libsbsms/files/libsbsms-2.0.2-cflags.patch
@@ -0,0 +1,24 @@
+--- libsbsms-2.0.2/configure.ac
++++ libsbsms-2.0.2/configure.ac
+@@ -69,8 +69,6 @@
+
+ AC_ARG_ENABLE(universal_binary,[ --enable-universal_binary enable universal binary build: (default: disable)],[enable_universal_binary=$enableval],[enable_universal_binary=no])
+
+-SBSMS_CFLAGS="-ffast-math -funroll-loops"
+-
+ if test x$enable_static = xno; then
+ case "$target_os" in
+ darwin*)
+@@ -81,12 +79,6 @@
+ esac
+ fi
+
+-if test x$enable_debug = xyes; then
+- SBSMS_CFLAGS="$SBSMS_CFLAGS -g -O3"
+-else
+- SBSMS_CFLAGS="$SBSMS_CFLAGS -O3 -fomit-frame-pointer"
+-fi
+-
+ if test x$enable_multithreaded = xyes; then
+ AC_DEFINE(MULTITHREADED,1,[Define to compile multithreaded sbsms])
+ fi
diff --git a/media-libs/libsbsms/libsbsms-2.0.0.ebuild b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
new file mode 100644
index 000000000000..2765261b478f
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="http://sbsms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/libsbsms/libsbsms-2.0.1.ebuild b/media-libs/libsbsms/libsbsms-2.0.1.ebuild
new file mode 100644
index 000000000000..d1a844c3ccd2
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="http://sbsms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.0.0-cflags.patch \
+ "${FILESDIR}"/${PN}-2.0.1-includes.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/libsbsms/libsbsms-2.0.2.ebuild b/media-libs/libsbsms/libsbsms-2.0.2.ebuild
new file mode 100644
index 000000000000..71f0accd2ed7
--- /dev/null
+++ b/media-libs/libsbsms/libsbsms-2.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A library for high quality time and pitch scale modification"
+HOMEPAGE="http://sbsms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sbsms/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ~ppc64 x86"
+IUSE="cpu_flags_x86_sse static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ --disable-multithreaded
+ # threaded version causes segfaults
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/libsbsms/metadata.xml b/media-libs/libsbsms/metadata.xml
new file mode 100644
index 000000000000..8b48dd28506f
--- /dev/null
+++ b/media-libs/libsbsms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <upstream>
+ <remote-id type="sourceforge">sbsms</remote-id>
+ </upstream>
+</pkgmetadata>