summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libyami/libyami-9999.ebuild')
-rw-r--r--media-libs/libyami/libyami-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-libs/libyami/libyami-9999.ebuild b/media-libs/libyami/libyami-9999.ebuild
index be54eaa446bf..6cd57db8c9f2 100644
--- a/media-libs/libyami/libyami-9999.ebuild
+++ b/media-libs/libyami/libyami-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,8 +19,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
else
KEYWORDS="~amd64"
- SRC_URI="https://github.com/01org/libyami/archive/${P}.tar.gz"
- S="${WORKDIR}/${PN}-${P}"
+ SRC_URI="https://github.com/01org/libyami/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="Apache-2.0"
@@ -47,6 +46,9 @@ DEPEND="${RDEPEND}
src_prepare() {
sed -i -e 's/-Werror//' configure.ac || die
+ sed -e 's#$(top_srcdir)/gtestsrc/libgtest.la#-lgtest#' -i */Makefile.unittest || die
+ sed -e 's#-I$(top_srcdir)/gtestsrc/gtest/include##' -i */Makefile.unittest || die
+ sed -e 's/gtestsrc//' -i Makefile.am || die
eautoreconf
}
@@ -61,7 +63,7 @@ multilib_src_configure() {
$(use_enable dmabuf) \
$(use_enable md5) \
$(use_enable wayland) \
- $(use_enable test gtest) \
+ $(use_enable test tests) \
$(multilib_native_use_enable doc docs) \
--enable-h265dec \
--enable-vc1dec \