summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensubdiv/opensubdiv-3.1.0.ebuild')
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.1.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
deleted file mode 100644
index aa63d90eeda4..000000000000
--- a/media-libs/opensubdiv/opensubdiv-3.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-utils toolchain-funcs versionator
-
-DESCRIPTION="An Open-Source subdivision surface library"
-HOMEPAGE="http://graphics.pixar.com/opensubdiv/"
-
-MY_PV="$(replace_all_version_separators '_')"
-
-SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="cuda doc opencl openmp ptex tbb test"
-
-RDEPEND="media-libs/glew:=
- media-libs/glfw:=
- cuda? ( dev-util/nvidia-cuda-toolkit:* )
- ptex? ( media-libs/ptex )"
-
-DEPEND="${RDEPEND}
- tbb? ( dev-cpp/tbb )
- doc? ( dev-python/docutils app-doc/doxygen )"
-
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}"/OpenSubdiv-${MY_PV}
-
-PATCHES=( "${FILESDIR}"/${P}-skip-osd-regression.patch )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- local mycmakeargs=(
- -DNO_MAYA=1
- -DNO_CLEW=1
- -DNO_DOC=$(usex !doc)
- -DNO_TBB=$(usex !tbb)
- -DNO_PTEX=$(usex !ptex)
- -DNO_OMP=$(usex !openmp)
- -DNO_OPENCL=$(usex !opencl)
- -DNO_CUDA=$(usex !cuda)
- -DNO_REGRESSION=$(usex !test)
- -DNO_EXAMPLES=1 # broken
- -DNO_TUTORIALS=1 # broken
- -DGLEW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- -DGLFW_LOCATION="${EPREFIX}/usr/$(get_libdir)"
- )
-
- cmake-utils_src_configure
-}