summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opus/opus-1.2_alpha.ebuild')
-rw-r--r--media-libs/opus/opus-1.2_alpha.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/opus/opus-1.2_alpha.ebuild b/media-libs/opus/opus-1.2_alpha.ebuild
new file mode 100644
index 000000000000..79f8f61e5992
--- /dev/null
+++ b/media-libs/opus/opus-1.2_alpha.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+else
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${P/_/-}.tar.gz"
+ if [[ "${PV}" != *_alpha* ]] && [[ "${PV}" != *_beta* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+ fi
+fi
+
+DESCRIPTION="Open versatile codec designed for interactive speech and audio transmission over the internet"
+HOMEPAGE="http://opus-codec.org/"
+
+LICENSE="BSD-2"
+SLOT="0"
+INTRINSIC_FLAGS="cpu_flags_x86_sse neon"
+IUSE="ambisonics custom-modes doc static-libs ${INTRINSIC_FLAGS}"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${P/_/-}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable ambisonics)
+ $(use_enable doc)
+ )
+ for i in ${INTRINSIC_FLAGS} ; do
+ use ${i} && myeconfargs+=( --enable-intrinsics )
+ done
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
+}