summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sbc/sbc-1.2.ebuild')
-rw-r--r--media-libs/sbc/sbc-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/sbc/sbc-1.2.ebuild b/media-libs/sbc/sbc-1.2.ebuild
new file mode 100644
index 000000000000..44afba07841f
--- /dev/null
+++ b/media-libs/sbc/sbc-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="An audio codec to connect bluetooth high quality audio devices like headphones or loudspeakers"
+HOMEPAGE="http://git.kernel.org/?p=bluetooth/sbc.git http://www.bluez.org/sbc-10/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 x86"
+IUSE="static-libs"
+
+# --enable-tester is building src/sbctester but the tarball is missing required
+# .wav file to execute it
+RESTRICT="test"
+
+DEPEND="virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tester
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}