summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild88
-rw-r--r--media-libs/gst-plugins-base/Manifest1
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.20.2.ebuild149
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild53
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild28
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.20.2.ebuild43
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.20.2.ebuild72
12 files changed, 439 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 4003cc12c92a..386a4b50cda9 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -3,3 +3,4 @@ DIST gst-plugins-bad-1.18.4-glib-volatile.patch.bz2 8492 BLAKE2B 7a6e4a3fc1d68c3
DIST gst-plugins-bad-1.18.4.tar.xz 5640292 BLAKE2B 5385abe635a35f61c6780e6cfa1189835877b8c0a12145de6890708a097fc453b1abfb14a3497cae4e6961f71fc2c6e01759fe19386cd30a64c4069704ddf77a SHA512 02123e054419f5ce6ca2ebe0bdf23572269ea4120bf463b4d672efbe5d9e5d417d4d711cc80094be974c4569f754d8b2ad93f59b827e3b018d450582834cb125
DIST gst-plugins-bad-1.18.6.tar.xz 5652788 BLAKE2B d877c8b6d39b67de957f180fbcc942fc658631dfc75b90f342f088e58c4655b1591651fbcd2a98259c95f0a7e830bb0ec67f65eb87d4b13c9f2adc733da7f12f SHA512 78731e0db04afd3dcdd5c5ea84df4e096a5db121fd9cb6eb79197844482a3b36b2764a664f171f80c809e6182ceae2350113d47f3f7c684d2d88f752bc092baf
DIST gst-plugins-bad-1.20.1.tar.xz 6212148 BLAKE2B e88f6553668329abb7b787c5efb89d760e60009fb9bd23884aa54e5a8de94f50b9fc9cd74cb2d303d43511207574f447bf616d8f9836df5dcde767c4ee5bff4d SHA512 3113fc93bba59716e7a506cf00f88cb05ccfe3406515ecf7e377dcfd3a8f4e555ff45126c048dc736ae6a28acf430c96422be4a120889fbe04ed69c5acb1cad6
+DIST gst-plugins-bad-1.20.2.tar.xz 6216208 BLAKE2B bbbe77a1255991a2f96696996fb0c99f14f6d63fef455feb1ce90ae518bb9f80fd61bcfb223c20407b8d6240faaa93478495f8e9fda16fab36a311d167e88e25 SHA512 3f98973dc07ead745418e0a30f9f6b5c8d328e3d126f54d92c10ab5da04271768a5c5dffc36ea24ccf8fb516b1e3733be9fb18dc0db419dea4d37d17018f8a70
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild
new file mode 100644
index 000000000000..ffccda97c31c
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.20.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-bad"
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit flag-o-matic gstreamer-meson python-any-r1
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# TODO: egl and gtk IUSE only for transition
+IUSE="X bzip2 +egl gles2 gtk +introspection +opengl +orc vnc wayland" # Keep default IUSE mirrored with gst-plugins-base where relevant
+
+# X11 is automagic for now, upstream #709530 - only used by librfb USE=vnc plugin
+# We mirror opengl/gles2 from -base to ensure no automagic openglmixers plugin (with "opengl?" it'd still get built with USE=-opengl here)
+# FIXME gtk? ( >=media-plugins/gst-plugins-gtk-${PV}:${SLOT}[${MULTILIB_USEDEP}] )
+RDEPEND="
+ !media-plugins/gst-transcoder
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl?,introspection?,gles2=,opengl=]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ vnc? ( X? ( x11-libs/libX11[${MULTILIB_USEDEP}] ) )
+ wayland? (
+ >=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.15
+ )
+
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# FIXME: gstharness.c:889:gst_harness_new_with_padnames: assertion failed: (element != NULL)
+RESTRICT="test"
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ addpredict /dev # Prevent sandbox violations bug #570624
+}
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="shm ipcpipeline librfb hls"
+
+ local emesonargs=(
+ -Dshm=enabled
+ -Dipcpipeline=enabled
+ -Dhls=disabled
+ $(meson_feature vnc librfb)
+
+ $(meson_feature wayland)
+ )
+
+ if use opengl || use gles2; then
+ myconf+=( -Dgl=enabled )
+ else
+ myconf+=( -Dgl=disabled )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_test() {
+ # Tests are slower than upstream expects
+ CK_DEFAULT_TIMEOUT=300 gstreamer_multilib_src_test
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/gst-plugins-base/Manifest b/media-libs/gst-plugins-base/Manifest
index 55b44aec1de0..cd869a910f24 100644
--- a/media-libs/gst-plugins-base/Manifest
+++ b/media-libs/gst-plugins-base/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-base-1.16.3.tar.xz 3953616 BLAKE2B c78713d0aa77a7e8c8043377a7b7
DIST gst-plugins-base-1.18.4.tar.xz 3169512 BLAKE2B 8b5a7a08641532631842e2ec02379b116ae0f08cda7654d123dbb2d56f97667b94ffc716b389a14ad034d0edb36587d8edc2c4f53782135c53def248fa60d0a3 SHA512 c750d68404462807ff03f441e232c4d98752a9bceeec3038fb37a105942f25499bde0660ca688b6f3204c58eb6a2e3f33671e979018c8bd829e7591455961a6a
DIST gst-plugins-base-1.18.6.tar.xz 3180564 BLAKE2B ad68cd65cff362ea990b26b9669edc6fe9be21e178e84d7db9d5d4fb13e31326ad7d40cc6228ed5bd54b74aad8a085332d6ce005519208ce6c3d397c29ca0a94 SHA512 b63c80354f1e7363e776726246328781a598a9739ab51b91db552935e5e4e96145ceb7b5b16bff6d054497ed37189bf742ae66774c23b1921b8b19bd9ab93945
DIST gst-plugins-base-1.20.1.tar.xz 3290068 BLAKE2B 56619a3c267d38daedc1d05b6ab95e8b66dba7bd9e30b019801146688b706f84551290de607d5d2e6f31f2a87302ab75db5cb9704623b4cc11e4aa5c327922c5 SHA512 679a0eee1973fa9612e2e24978e2c2d9d8fdc5732e1699b4a87712881f1549d0811719a13ff4fe77b91322ca4425c39623b371703f6b3a36fb7238b977d3e541
+DIST gst-plugins-base-1.20.2.tar.xz 3295552 BLAKE2B 23b306c566cdd57e31b84082bd14c93e84a10329d83ac71365c0ba7f523d1415ac36aa8217c982abe0c33a40da6e884fac66737227eb794b5bc0c64944d7ea36 SHA512 144ae965a3e487c70e9ac55099ae49f54bff7110d5a92867ebe8a91760dd94fb7f13dc23f34e55923c2150012f81b55be22c840fe89d97e4e78290cb6d51bc51
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.20.2.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.20.2.ebuild
new file mode 100644
index 000000000000..11cce3fa5f2d
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.20.2.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-base"
+
+inherit flag-o-matic gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# For OpenGL we have three separate concepts, with a list of possibilities in each:
+# * opengl APIs - opengl and/or gles2; USE=opengl and USE=gles2 enable these accordingly; if neither is enabled, OpenGL helper library and elements are not built at all and all the other options aren't relevant
+# * opengl platforms - glx and/or egl; also cgl, wgl, eagl for non-linux; USE="X opengl" enables glx platform; USE="egl" enables egl platform. Rest is up for relevant prefix teams.
+# * opengl windowing system - x11, wayland, win32, cocoa, android, viv_fb, gbm and/or dispmanx; USE=X enables x11 (but for WSI it's automagic - FIXME), USE=wayland enables wayland, USE=gbm enables gbm (automagic upstream - FIXME); rest is up for relevant prefix/arch teams/contributors to test and provide patches
+# With the following limitations:
+# * If opengl and/or gles2 is enabled, a platform has to be enabled - x11 or egl in our case, but x11 (glx) is acceptable only with opengl
+# * If opengl and/or gles2 is enabled, a windowing system has to be enabled - x11, wayland or gbm in our case
+# * glx platform requires opengl API
+# * wayland, gbm and most other non-glx WSIs require egl platform
+# Additionally there is optional dmabuf support with egl for additional dmabuf based upload/download/eglimage options;
+# and optional graphene usage for gltransformation and glvideoflip elements and more GLSL Uniforms support in glshader;
+# and libpng/jpeg are required for gloverlay element;
+
+# Keep default IUSE options for relevant ones mirrored with gst-plugins-gtk and gst-plugins-bad
+IUSE="alsa +egl gbm gles2 +introspection ivorbis +ogg +opengl +orc +pango theora +vorbis wayland +X"
+GL_REQUIRED_USE="
+ || ( gbm wayland X )
+ wayland? ( egl )
+ gbm? ( egl )
+"
+REQUIRED_USE="
+ ivorbis? ( ogg )
+ theora? ( ogg )
+ vorbis? ( ogg )
+ opengl? ( || ( egl X ) ${GL_REQUIRED_USE} )
+ gles2? ( egl ${GL_REQUIRED_USE} )
+"
+
+# Dependencies needed by opengl library and plugin (enabled via USE gles2 and/or opengl)
+# dmabuf automagic from libdrm headers (drm_fourcc.h) and EGL, so ensure it with USE=egl (platform independent header used only, thus no MULTILIB_USEDEP); provides dmabuf based upload/download/eglimage options
+GL_DEPS="
+ >=media-libs/mesa-9.0[egl(+)?,gbm(+)?,gles2?,wayland?,${MULTILIB_USEDEP}]
+ egl? (
+ x11-libs/libdrm
+ )
+ gbm? (
+ >=dev-libs/libgudev-147[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
+ )
+ wayland? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.15
+ )
+
+ >=media-libs/graphene-1.4.0[${MULTILIB_USEDEP}]
+ media-libs/libpng:0[${MULTILIB_USEDEP}]
+ virtual/jpeg:0[${MULTILIB_USEDEP}]
+" # graphene for optional gltransformation and glvideoflip elements and more GLSL Uniforms support in glshader; libpng/jpeg for gloverlay element
+# >=media-libs/graphene-1.4.0[${MULTILIB_USEDEP}]
+
+RDEPEND="
+ app-text/iso-codes
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ ivorbis? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+ ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ orc? ( >=dev-lang/orc-0.4.24[${MULTILIB_USEDEP}] )
+ pango? ( >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}] )
+ vorbis? ( >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}]
+ )
+
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.15.0:1.0
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ X? ( x11-base/xorg-proto )
+"
+
+DOCS=( AUTHORS NEWS README.md RELEASE )
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ filter-flags -mno-sse -mno-sse2 -mno-sse4.1 #610340
+
+ # opus: split to media-plugins/gst-plugins-opus
+ GST_PLUGINS_NOAUTO="alsa ogg pango theora vorbis x11 xshm xvideo"
+
+ local emesonargs=(
+ -Dtools=enabled
+
+ $(meson_feature alsa)
+ $(meson_feature ogg)
+ $(meson_feature orc)
+ $(meson_feature pango)
+ $(meson_feature theora)
+ $(meson_feature vorbis)
+ $(meson_feature X x11)
+ $(meson_feature X xshm)
+ $(meson_feature X xvideo)
+ )
+
+ if use opengl || use gles2; then
+ # because meson doesn't likes extraneous commas
+ local gl_api=( $(use opengl && echo opengl) $(use gles2 && echo gles2) )
+ local gl_platform=( $(use X && echo glx) $(use egl && echo egl) )
+ local gl_winsys=(
+ $(use X && echo x11)
+ $(use wayland && echo wayland)
+ $(use egl && echo egl)
+ $(use gbm && echo gbm)
+ )
+
+ emesonargs+=(
+ -Dgl=enabled
+ -Dgl-graphene=enabled
+ -Dgl_api=$(IFS=, ; echo "${gl_api[*]}")
+ -Dgl_platform=$(IFS=, ; echo "${gl_platform[*]}")
+ -Dgl_winsys=$(IFS=, ; echo "${gl_winsys[*]}")
+ )
+ else
+ emesonargs+=(
+ -Dgl=disabled
+ -Dgl_api=
+ -Dgl_platform=
+ -Dgl_winsys=
+ )
+ fi
+
+ # Workaround EGL/eglplatform.h being built with X11 present
+ use X || export CFLAGS="${CFLAGS} -DEGL_NO_X11"
+
+ gstreamer_multilib_src_configure
+}
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 7f7eecc061a2..1ef4a23337dc 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-good-1.16.3.tar.xz 3914676 BLAKE2B 52f18027f9d9a77e8b459a0a10fa
DIST gst-plugins-good-1.18.4.tar.xz 3277572 BLAKE2B 8acfb975d19eabc681184d0096328051a9a02e5f849599dbad1233a0e9254e1a2d2bef75d8afdc779a7ca01a71b15d1e83a843749c0ef5f7ab2b5818067ab898 SHA512 764c66383c93e57f9c5e7742002013e07e7b25750d6974d6c07744433e8ceb7570e829e68278e2bc5214f77158311a6b3bfb013d615cf66205d8d7a9e2d54b86
DIST gst-plugins-good-1.18.6.tar.xz 3296552 BLAKE2B 551ae9cf9beb512ae418db20cd50dc8826ed60421a40d6c9c9fc558f32c9db2a9bada309a8075306542c53382ecb728dac3dd6252d1efc7255cffde0bea35895 SHA512 e0be5f1eaffe65d7871f23e42645fa4cee30953d16d54c4f4707c094859659cff1e4609b086afebaf08777b6d01dcba4f4b2b338e722bf729e9ed0482a2417a5
DIST gst-plugins-good-1.20.1.tar.xz 3415220 BLAKE2B 62a0e0b4d60412350c3aad692e7b3d0dd5c7ebed098e21e7d4d7c599ffec9be5795c88cbdece0b219d1aad607ad1a0209a376a8f3543793c9c905cb1401e92c4 SHA512 6e56f6290465da03bfe162228829e51091896b2c5fe9d1d0718f663a3ab14edf5c790b37998a783981b9c77034252e7dee9fec5136f92ced44c4898e2fbd402e
+DIST gst-plugins-good-1.20.2.tar.xz 3411008 BLAKE2B 45eb497d240bf9b05cfbf85babe5ef85fb8a7f25f1b470f131f319064e1dc04f334d4b7dede4f0aedd73dca01605b7e00e2ddc587bcf9ccce6989a9e99776cb1 SHA512 a10ea48fdfbe741e9bc63036b011748558f89968aaa525380ac99884c27463d190c0b49e2d98b4f554eee6ead8a5c5da3ba62e5b0b1fe54877598beccc68a933
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild
new file mode 100644
index 000000000000..de6939296c03
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.20.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit flag-o-matic gstreamer-meson
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+# Fixes backported to 1.20.1, to be removed in 1.20.2+
+PATCHES=(
+)
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="bz2"
+
+ local emesonargs=(
+ -Dbz2=enabled
+
+ # gst-plugins-ximagesrc
+ -Dximagesrc=disabled
+ -Dximagesrc-xshm=disabled
+ -Dximagesrc-xfixes=disabled
+ -Dximagesrc-xdamage=disabled
+
+ # gst-plugins-v4l2
+ -Dv4l2=disabled
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
index 35d2a944527d..b70d5366d925 100644
--- a/media-libs/gst-plugins-ugly/Manifest
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-ugly-1.16.3.tar.xz 899124 BLAKE2B f848c7bbf36cdfca6e3dec4893b9b
DIST gst-plugins-ugly-1.18.4.tar.xz 509920 BLAKE2B a7aec6ac6e5739205c9567072596a8fb6dfcabc2f56ee0800c430c9bfc9549bf7ac75cb65719dadeb84036130d5b58f9be574f2a6531992ee7a8f23e9fb32d16 SHA512 eac02000ac3e0a54a953fe1531cb29bc6bc9913a707d1508905bf64fe0a4ef92f7d01b196259fc217fac8a344f0b2d683dd6d32210ce6b8c0acab08cb3b1322a
DIST gst-plugins-ugly-1.18.6.tar.xz 515236 BLAKE2B 9f68321e5b58e49989630838fb8fa33da22b887c11735efde1460e0d857644c14a856f7dbd5337e0f2a4791f6934ddeb4defb22e7be70aa8c246b0439fdd9136 SHA512 86c8c536644885d4e1c6691d390ff13faa401f62baa964453c61909f1a1d13a7c43f0cfa5f7a05cc7a34cc90227b1b77244e84024c4c776797f1501c8defe10f
DIST gst-plugins-ugly-1.20.1.tar.xz 504136 BLAKE2B a3e0e7934feab2efb38dcfa8a034eca9bd3010051b0a6b6c09f100f4a356dc9e8654c45b7e124e4a0e3ac5174f2be6b4362df26bb94df61d899453e10dfbb2ff SHA512 cf4db5da474cba86e19ed399014dff8d0ed3a51feaaaf3a25779af23f5996b6d28c8c9237ad7b4d47051e4336c3b2b467094aed39bf15c8c25b7a6fe9508e6d5
+DIST gst-plugins-ugly-1.20.2.tar.xz 506672 BLAKE2B d1ca3075182a7fe431884c29f12ce9ec60bea3fa0e701a02981f1bf4f6ba393890712373be7a5f0b76734ccf80a5dc1240f62505f2ffe1ab12f1a314ce82bbe4 SHA512 bbe6c60003dc180084995aa00c8aefc5238f9e826db03f5cadac4a39900f2e9ca529b8f63787ca59c830e12bf4f426408b185ca228bd5e9255c2a4f452a48d6a
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
new file mode 100644
index 000000000000..4c3c48b389b5
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.20.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-ugly"
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit gstreamer-meson python-any-r1
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+orc"
+
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index 6f6980482ac3..6c2490c919aa 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -2,3 +2,4 @@ DIST gst-rtsp-server-1.16.3.tar.xz 699472 BLAKE2B 8937ce9d0550b11657496dec5a79c0
DIST gst-rtsp-server-1.18.4.tar.xz 358140 BLAKE2B 3c8dae60742cc35580d5dbb4bbc5175ee93de2d2bb64c0de0dd09df5137b2b1518f6a39a2538d1eca86e8bd756299cada6f26ae23f33e1af1d6317e1e30d9d63 SHA512 1cda671f43e608d89aa024a8b4a39cbe1b83e1cd822b1190c777dd18c2000b5c8370e50598821b9c3f348776a418286a26993acf4255c6ff488682e0addeefab
DIST gst-rtsp-server-1.18.6.tar.xz 364472 BLAKE2B 7fe0f70130f2e8022cc9308e8bde1c889c918e34edcfb633c0edf4e674f1b88610ec975cf67aca123193a22025512afbd3d5ab71df6b3d69eea44e56fab30602 SHA512 11c637fe263a9a55820be51fc3cef0aef06af5dc06ab20786b804412ee16ca7abdf20261b10e7483accde390ba75a921b050ab7a2f737145780815cd47f8f5f8
DIST gst-rtsp-server-1.20.1.tar.xz 358032 BLAKE2B 53dc0936a6a67b75c636d5170549b10456a68679e7fb5cfc6ad5a9d3e56044ddd93bbe25353fdd9f102155d831de48e8dbecc0697b767f9c2e03e4c1d1460a4e SHA512 8f1cf76602e55fbeaa77cd757c2a1380a792909a53e00cb29a4978789f37ee56493ce3fcb652769cdd47ccb935bba0291908d16fa506b58bcc65f34d303ac963
+DIST gst-rtsp-server-1.20.2.tar.xz 360388 BLAKE2B 6593a83e8746001c26abe623608390448f8cbe6710e3215eeea483940a2fb544617ac159a2e03ba3c84918d8132fbad1a91d638491a226dd13e83f87a3219d7d SHA512 fac3338603f1e31cb1da3c163784fbed1663e0cee722b47c3a6bb369296e5fbff3fdc9925952fe387d51f05ffaeef2a7400369a7006b805f3cb8b454566642bd
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.2.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.2.ebuild
new file mode 100644
index 000000000000..b48154a12921
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.20.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-rtsp-server.html"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs"
+
+# gst-plugins-base for many used elements and API
+# gst-plugins-good for rtprtxsend and rtpbin elements, maybe more
+# gst-plugins-srtp for srtpenc and srtpdec elements
+RDEPEND="
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-plugins/gst-plugins-srtp-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+ )
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc "${S}"/examples/*.c
+ fi
+}
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index f86931733814..cdd8b601c7ab 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -2,3 +2,4 @@ DIST gstreamer-1.16.3.tar.xz 3338692 BLAKE2B 79eb08bc446073fadf881adea0f60a2caf6
DIST gstreamer-1.18.4.tar.xz 2703948 BLAKE2B b11be1309e7a6ad0aff24aa99b10b1c16df4b1720b821421a72ec9d9b20087488901bb4667e797d32ef616f909c3aefd301fac6be9c4c4120ec9e4af3acc7b48 SHA512 5312c621fc354b35cc81f53b4ec65c661ad2c22acef2640bc27860234243d06e00e3aaf41c93d379d8424c0ecdf2ae06096dec0d0313215426348ffa0afb3c4a
DIST gstreamer-1.18.6.tar.xz 2713892 BLAKE2B 93642e33f0812cae60318ac821fcda450b15894e44d17e1e4dae3a9d84f20e86bbb418bf924fdf2cc52e4bcbbea8cf8fac530157bc48e43fb86819c587ad1aab SHA512 9598da87a6e87ddd134542dd72e110ce53bb673a8f29484d85ce4daff2a19e1fb5c392ddad460d0bb9138a51ae65f06ba2e7251636bbee272070feea428facac
DIST gstreamer-1.20.1.tar.xz 2674128 BLAKE2B c05c29ac53df2ed5d60c3f2e9dcbc130e4733bc19fbb23b31285190cd68e5abd2a9209e87b4cd481719944b4fcdf6b0e1dbc1a7ba93cfa96fd305e698f971b3a SHA512 d6f67cce81ba15fba3fcf70850e3c84b25e8da3e53fd56e6f2c87c7ee1701071ea44deb754a0ea371b3cb17877f26aab94d9eccb6729cbb370d6d6d5c324aa1a
+DIST gstreamer-1.20.2.tar.xz 2677552 BLAKE2B 0e6a818fd900c4f0c2748f15262e1d166755e3c419dfa04d7fc4a434ad9a84474d0eb43b9cf0286008497d7ff3e5340b737aeafc45d2994d7c713d5a12e3e2e3 SHA512 994378b656fa593e134624d5d4d5014e78074199d80152eafce29bc09864bd6d0f32a31eafda6cb8caec60aa85b0bda7c42a8c3b388b47d59f2cf4bc729d551f
diff --git a/media-libs/gstreamer/gstreamer-1.20.2.ebuild b/media-libs/gstreamer/gstreamer-1.20.2.ebuild
new file mode 100644
index 000000000000..ffbe7db340d4
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.20.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection +orc unwind"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
+ unwind? (
+ >=sys-libs/libunwind-1.2_rc1[${MULTILIB_USEDEP}]
+ dev-libs/elfutils[${MULTILIB_USEDEP}]
+ )
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS ChangeLog NEWS MAINTAINERS README.md RELEASE )
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dcheck=enabled
+ $(meson_feature unwind libunwind)
+ $(meson_feature unwind libdw)
+ )
+
+ if use caps ; then
+ emesonargs+=( -Dptp-helper-permissions=capabilities )
+ else
+ emesonargs+=(
+ -Dptp-helper-permissions=setuid-root
+ -Dptp-helper-setuid-user=nobody
+ -Dptp-helper-setuid-group=nobody
+ )
+ fi
+
+ gstreamer_multilib_src_configure
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ DESTDIR="${D}" eninja install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}/usr/bin/gst-launch-${SLOT}"
+}