summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.1.ebuild')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.1.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.1.ebuild
new file mode 100644
index 000000000000..8b713384aec1
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.20.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package gstcodecparsers_dep:gstreamer-codecparsers
+ gstreamer_system_library gstisoff_dep:gstisoff
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}