summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mediastreamer-silk/mediastreamer-silk-0.0.1.ebuild')
-rw-r--r--media-plugins/mediastreamer-silk/mediastreamer-silk-0.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/mediastreamer-silk/mediastreamer-silk-0.0.1.ebuild b/media-plugins/mediastreamer-silk/mediastreamer-silk-0.0.1.ebuild
new file mode 100644
index 000000000000..588ec2fad506
--- /dev/null
+++ b/media-plugins/mediastreamer-silk/mediastreamer-silk-0.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="mssilk"
+SDK_FILE="SILK_SDK_SRC_v1.0.8.zip" # please update silk version on bumps!
+
+inherit autotools eutils
+
+DESCRIPTION="SILK (skype codec) implementation for Linphone"
+HOMEPAGE="http://www.linphone.org"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_PN}-${PV}.tar.gz
+ http://developer.skype.com/silk/${SDK_FILE}"
+
+LICENSE="GPL-2+ Clear-BSD SILK-patent-license"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+RDEPEND=">=media-libs/mediastreamer-2.8.2:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+RESTRICT="bindist mirror" # silk license forbids distribution
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-sdk.patch"
+ eautoreconf
+}