summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-prefermenu')
-rw-r--r--media-plugins/vdr-prefermenu/Manifest1
-rw-r--r--media-plugins/vdr-prefermenu/files/prefermenu.mk124
-rw-r--r--media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff73
-rw-r--r--media-plugins/vdr-prefermenu/metadata.xml12
-rw-r--r--media-plugins/vdr-prefermenu/vdr-prefermenu-0.6.6-r2.ebuild38
5 files changed, 248 insertions, 0 deletions
diff --git a/media-plugins/vdr-prefermenu/Manifest b/media-plugins/vdr-prefermenu/Manifest
new file mode 100644
index 000000000000..e3ad13e04ae3
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/Manifest
@@ -0,0 +1 @@
+DIST vdr-prefermenu-0.6.6.tgz 19617 SHA256 0b9338d1fff19e5ccf1f4e9f352e7bdf5b4f5e129007aa147d7ee4ab1034a6e8 SHA512 bc5e11757979a60f408c59d4d0f1d713899013d4a3485ff85e7bf139fb8f436ddd80799673c3d7a718a3d9cc0e75c216f73f1eccc3c2350826c5f8d6145157f6 WHIRLPOOL 5af73e6a2a7ceebdc733abdd16000521007f6fd046cfcfd4fac0909d572982342b780ba754e97e1e4f6a674f04446db2cdbf6ed220d40a82a4f8ad8eca23bc95
diff --git a/media-plugins/vdr-prefermenu/files/prefermenu.mk b/media-plugins/vdr-prefermenu/files/prefermenu.mk
new file mode 100644
index 000000000000..8021b75536a0
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/files/prefermenu.mk
@@ -0,0 +1,124 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id$
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = prefermenu
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+#INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o preferosd.o prefersetup.o preferchannel.o
+
+### The main target:
+
+all: $(SOFILE)
+#i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib
+#install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+# @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff b/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff
new file mode 100644
index 000000000000..0c0239d2ac48
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff
@@ -0,0 +1,73 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 90_prefermenu-0.6.6-1.5.3.dpatch by Thomas Günther <tom@toms-cafe.de>
+## http://toms-cafe.de/vdr/download/prefermenu-0.6.6-1.5.3.diff
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Changes for VDR >= 1.5.3.
+
+@DPATCH@
+--- prefermenu-0.6.6/prefermenu.c
++++ prefermenu-0.6.6/prefermenu.c
+@@ -75,6 +75,7 @@
+ }
+ // Clean up the file with current VDR channels.conf
+ PreferedChannelsList.Save();
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ config.height= (config.lines * (LINEHEIGHT+BORDERSIZE+2))+BORDERSIZE;
+ return new cPreferOsd;
+ }
+--- prefermenu-0.6.6/preferosd.c
++++ prefermenu-0.6.6/preferosd.c
+@@ -60,6 +60,7 @@
+ }
+ osd=cOsdProvider::NewOsd(config.originx, config.originy);
+ if (osd) {
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ tArea Area = { 0, 0, config.width+LINEHEIGHT, config.height-1, 4};
+ osd->SetAreas(&Area, 1);
+ DrawPreferMenu(0,0);
+@@ -168,6 +169,7 @@
+ {
+ if (current > 1) {
+ current -= 1;
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ DrawPreferMenu(-LINEHEIGHT,1);
+ DisplayPreferMenu();
+ //DrawPreferMneu(-10,1);
+@@ -181,6 +183,7 @@
+ {
+ if (current < number) {
+ current += 1;
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ DrawPreferMenu(+LINEHEIGHT,-1);
+ DisplayPreferMenu();
+ //DrawPreferMenu(+10,-1);
+@@ -315,6 +318,8 @@
+
+ void cPreferOsd::DrawPreferMenu(int delta, int highlight)
+ {
++ const cFont *font = cFont::GetFont(fontOsd);
++ const int LINEHEIGHT = font->Height();
+
+ int middle = int(config.height/2) + config.height%2;
+
+@@ -390,6 +395,8 @@
+
+ void cPreferOsd::DrawChannelsNames(int delta)
+ {
++ const cFont *font = cFont::GetFont(fontOsd);
++ const int LINEHEIGHT = font->Height();
+
+ // XXX The margin is hardcoded for now
+ // TODO: make it more flexible
+--- prefermenu-0.6.6/preferosd.h
++++ prefermenu-0.6.6/preferosd.h
+@@ -4,8 +4,6 @@
+ #include <vdr/plugin.h>
+
+ static const int BORDERSIZE = 2;
+-static const cFont *font = cFont::GetFont(fontOsd);
+-static const int LINEHEIGHT = font->Height();
+
+
+ class cPreferOsd : public cOsdObject {
diff --git a/media-plugins/vdr-prefermenu/metadata.xml b/media-plugins/vdr-prefermenu/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-prefermenu/vdr-prefermenu-0.6.6-r2.ebuild b/media-plugins/vdr-prefermenu/vdr-prefermenu-0.6.6-r2.ebuild
new file mode 100644
index 000000000000..7e533a61c281
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/vdr-prefermenu-0.6.6-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: presents a favourites channels menu"
+HOMEPAGE="http://www.olivierjacques.com/vdr/prefermenu/"
+SRC_URI="http://famillejacques.free.fr/vdr/prefermenu/vdr-${VDRPLUGIN}-${PV}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.0"
+
+PATCHES=("${FILESDIR}/${P}-no-static-getfont.diff")
+
+src_prepare() {
+ cp "${FILESDIR}/${VDRPLUGIN}.mk" Makefile
+
+ vdr-plugin-2_src_prepare
+
+ sed -e "s:RegisterI18n://RegisterI18n:" -i prefermenu.c
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ touch prefermenu.conf
+
+ insopts -m0644 -gvdr -ovdr
+ insinto /etc/vdr/plugins/prefermenu
+ doins prefermenu.conf
+}