summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-xine/files')
-rw-r--r--media-plugins/vdr-xine/files/confd8
-rw-r--r--media-plugins/vdr-xine/files/vdr-xine-0.9.4-build-system.patch59
-rw-r--r--media-plugins/vdr-xine/files/vdr-xine-0.9.4-gentoo.diff12
3 files changed, 79 insertions, 0 deletions
diff --git a/media-plugins/vdr-xine/files/confd b/media-plugins/vdr-xine/files/confd
new file mode 100644
index 000000000000..d728819e0041
--- /dev/null
+++ b/media-plugins/vdr-xine/files/confd
@@ -0,0 +1,8 @@
+# /etc/conf.d/vdr.xine:
+
+# Global config file for vdr rc-scripts
+
+# -r:
+# Enable xine to send keys to vdr-process
+
+_EXTRAOPTS="-r"
diff --git a/media-plugins/vdr-xine/files/vdr-xine-0.9.4-build-system.patch b/media-plugins/vdr-xine/files/vdr-xine-0.9.4-build-system.patch
new file mode 100644
index 000000000000..9ebaffb93c6b
--- /dev/null
+++ b/media-plugins/vdr-xine/files/vdr-xine-0.9.4-build-system.patch
@@ -0,0 +1,59 @@
+From 537ad5fa86305cf55f37dd9c87a9ec3260668049 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Tue, 10 Jan 2012 13:58:40 +0100
+Subject: [PATCH] patch 1
+
+---
+ Makefile | 14 ++++++++------
+ 1 files changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 674f4fb..e1fdba2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,9 +25,9 @@ CXXFLAGS ?= -g -O3 -Wall -Woverloaded-virtual
+
+ ### The directory environment:
+
+-VDRDIR = ../../..
+-LIBDIR = ../../lib
+-TMPDIR = /tmp
++VDRDIR ?= ../../..
++LIBDIR ?= ../../lib
++TMPDIR ?= /tmp
+
+ ### Make sure that necessary options are included:
+
+@@ -37,7 +37,7 @@ TMPDIR = /tmp
+
+ -include $(VDRDIR)/Make.config
+
+-INCLUDES += `pkg-config --cflags libxine`
++INCLUDES += `pkg-config --cflags libxine`
+
+ # where to create fifos (xine expects them at /tmp/vdr-xine)
+ VDR_XINE_FIFO_DIR ?= /tmp/vdr-xine
+@@ -114,9 +114,9 @@ $(DEPFILE): Makefile
+ -include $(DEPFILE)
+
+ ### Internationalization (I18N):
+-
++ifeq ($(ENABLE_I18N), yes)
+ PODIR = po
+-LOCALEDIR = $(VDRDIR)/locale
++LOCALEDIR = $(DESTDIR)$(VDRDIR)/locale
+ I18Npo = $(wildcard $(PODIR)/*.po)
+ I18Nmsgs = $(addprefix $(LOCALEDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+ I18Npot = $(PODIR)/$(PLUGIN).pot
+@@ -135,6 +135,8 @@ $(I18Nmsgs): $(LOCALEDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ @mkdir -p $(dir $@)
+ cp $< $@
+
++endif
++
+ .PHONY: i18n
+ i18n: $(I18Nmsgs) $(I18Npot)
+
+--
+1.7.3.4
+
diff --git a/media-plugins/vdr-xine/files/vdr-xine-0.9.4-gentoo.diff b/media-plugins/vdr-xine/files/vdr-xine-0.9.4-gentoo.diff
new file mode 100644
index 000000000000..581dba287372
--- /dev/null
+++ b/media-plugins/vdr-xine/files/vdr-xine-0.9.4-gentoo.diff
@@ -0,0 +1,12 @@
+diff -ru xine-0.9.0-orig/xineLib.c xine-0.9.0/xineLib.c
+--- xine-0.9.0-orig/xineLib.c 2009-01-18 17:40:13.228935882 +0100
++++ xine-0.9.0/xineLib.c 2009-01-18 17:41:28.815595331 +0100
+@@ -2118,7 +2118,7 @@
+
+ bool cXineLib::readNoSignalStream(const int index, const string &suffix)
+ {
+- string noSignalFileName = m_plugin->ConfigDirectory(PLUGIN_NAME_I18N);
++ string noSignalFileName = "/usr/share/vdr/xine";
+ // noSignalFileName += "/noSignal.pes";
+ noSignalFileName += "/noSignal" + suffix + ".mpg";
+