summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/kochmorse/kochmorse-3.4.0-r1.ebuild')
-rw-r--r--media-radio/kochmorse/kochmorse-3.4.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/kochmorse/kochmorse-3.4.0-r1.ebuild b/media-radio/kochmorse/kochmorse-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..066f0da13b21
--- /dev/null
+++ b/media-radio/kochmorse/kochmorse-3.4.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Morse-code tutor using the Koch method"
+HOMEPAGE="https://github.com/hmatuschek/kochmorse"
+SRC_URI="https://github.com/hmatuschek/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+BDEPEND="dev-qt/linguist-tools:5"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+ # Upstream uses a non-standard category in release 3.4.0
+ sed -i -e 's/Teaching;/X-Teaching;/' shared/${PN}.desktop || die
+}