summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild')
-rw-r--r--media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild b/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..5edc07ba8cfc
--- /dev/null
+++ b/media-sound/alac_decoder/alac_decoder-0.2.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Basic decoder for Apple Lossless Audio Codec files (ALAC)"
+HOMEPAGE="http://craz.net/programs/itunes/alac.html"
+SRC_URI="http://craz.net/programs/itunes/files/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~ppc-macos"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin alac
+ einstalldocs
+}