summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsamixergui')
-rw-r--r--media-sound/alsamixergui/Manifest1
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild47
-rw-r--r--media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch16
-rw-r--r--media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch11
-rw-r--r--media-sound/alsamixergui/files/segfault-on-exit.patch11
-rw-r--r--media-sound/alsamixergui/metadata.xml5
6 files changed, 91 insertions, 0 deletions
diff --git a/media-sound/alsamixergui/Manifest b/media-sound/alsamixergui/Manifest
new file mode 100644
index 000000000000..2ebb1ea87b32
--- /dev/null
+++ b/media-sound/alsamixergui/Manifest
@@ -0,0 +1 @@
+DIST alsamixergui-0.9.0rc1-2.tar.gz 70255 SHA256 6053a352580fa90fc5d35a2edce138759726acd72283ff6797cf7720632481cd SHA512 c1eac24c87e3d3dd8a582312a24e4f517d084845a3a0cd0a7253e3386685d72a691fe138853002b0277361d397271fbc9f445fd5ad0f5d604e5ad022a408d6b7 WHIRLPOOL 5215402cf2033a0f1584131d90c8a04f6f88921533bbff7ab600e2c0edf427fba6e594db6e5f41d25b11ab5a72c3c7ac503728b6940b6ce74db03368ae9540df
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
new file mode 100644
index 000000000000..afb6b6da0f77
--- /dev/null
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils flag-o-matic
+
+MY_P=${PN}-0.9.0rc1-2
+
+DESCRIPTION="FLTK based amixer Frontend"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/alsa-utils
+ x11-libs/fltk:1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc34.patch \
+ "${FILESDIR}"/segfault-on-exit.patch \
+ "${FILESDIR}"/${P}-fltk-1.1.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags "-L$(dirname $(fltk-config --libs))"
+ append-flags "-I/usr/include/fltk"
+ econf
+}
+
+src_install() {
+ default
+ newicon src/images/alsalogo.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Alsa Mixer GUI"
+}
diff --git a/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch
new file mode 100644
index 000000000000..a7c121dbc9d1
--- /dev/null
+++ b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch
@@ -0,0 +1,16 @@
+--- configure.in
++++ configure.in
+@@ -11,11 +11,11 @@
+ AC_PROG_LN_S
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(fltk,numericsort,,AC_MSG_ERROR("missing fltk"))
++AC_CHECK_LIB(fltk,fl_numericsort,,AC_MSG_ERROR("missing fltk"))
+ AM_PATH_ALSA(0.9.0)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_HAVE_HEADERS(stdio.h string.h stdlib.h getopt.h alsa/asoundlib.h FL/Fl.H)
++AC_HAVE_HEADERS(stdio.h string.h stdlib.h getopt.h alsa/asoundlib.h)
+
+ AC_OUTPUT(Makefile src/Makefile)
diff --git a/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch
new file mode 100644
index 000000000000..6f37970aa568
--- /dev/null
+++ b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch
@@ -0,0 +1,11 @@
+--- src/alsamixer.cxx
++++ src/alsamixer.cxx
+@@ -654,7 +654,7 @@
+ if (joined) {
+ #ifdef ALSAMIXER_GUI
+ for (chn = snd_mixer_selem_channel_id_t(0); chn < SND_MIXER_SCHN_LAST;
+- snd_mixer_selem_channel_id_t(int(chn)++))
++ snd_mixer_selem_channel_id_t(int(chn)+1))
+ #else
+ for (chn = 0; chn < SND_MIXER_SCHN_LAST; chn++)
+ #endif
diff --git a/media-sound/alsamixergui/files/segfault-on-exit.patch b/media-sound/alsamixergui/files/segfault-on-exit.patch
new file mode 100644
index 000000000000..6dc2feb8cc58
--- /dev/null
+++ b/media-sound/alsamixergui/files/segfault-on-exit.patch
@@ -0,0 +1,11 @@
+--- src/alsamixer.cxx
++++ src/alsamixer.cxx
+@@ -1869,7 +1869,7 @@
+ if (procWindow) delete procWindow;
+ if (mainWindow) delete mainWindow;
+ mainWindow = 0; procWindow = 0; helpWindow = 0;
+- return 0;
++ mixer_abort (ERR_NONE, "", 0);
+ #endif /* #ifdef ALSAMIXER_GUI */
+ break;
+ case 13: /* Return */
diff --git a/media-sound/alsamixergui/metadata.xml b/media-sound/alsamixergui/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/alsamixergui/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>