summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/bluez-alsa/bluez-alsa-9999.ebuild')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild60
1 files changed, 41 insertions, 19 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index c8620648df98..88b416794de8 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,53 +1,64 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools multilib-minimal systemd
+EAPI=8
+inherit autotools bash-completion-r1 multilib-minimal readme.gentoo-r1 systemd
DESCRIPTION="Bluetooth Audio ALSA Backend"
-HOMEPAGE="https://github.com/Arkq/bluez-alsa"
+HOMEPAGE="https://github.com/arkq/bluez-alsa"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/Arkq/${PN}"
+ EGIT_REPO_URI="https://github.com/arkq/${PN}"
else
- SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="aac debug hcitop lame ldac man mpg123 ofono static-libs test unwind upower"
+IUSE="aac aptx debug hcitop lame ldac liblc3 man mpg123 ofono static-libs systemd test unwind upower"
+
RESTRICT="!test? ( test )"
# bluez-alsa does not directly link to upower but
# is using the upower interface via dbus calls.
RDEPEND="
- >=dev-libs/glib-2.26[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.58.2[${MULTILIB_USEDEP}]
>=media-libs/alsa-lib-1.1.2[${MULTILIB_USEDEP}]
- >=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
- >=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
+ >=media-libs/sbc-1.5[${MULTILIB_USEDEP}]
+ >=net-wireless/bluez-5.51[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-libs/readline:0=
aac? ( >=media-libs/fdk-aac-0.1.1:=[${MULTILIB_USEDEP}] )
- lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
- mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ aptx? ( >=media-libs/libfreeaptx-0.1.1 )
hcitop? (
dev-libs/libbsd
sys-libs/ncurses:0=
)
+ lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
ldac? ( >=media-libs/libldac-2.0.0 )
+ liblc3? ( >=media-sound/liblc3-1.0.0 )
+ mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
ofono? ( net-misc/ofono )
+ systemd? ( sys-apps/systemd )
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
upower? ( sys-power/upower )
"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
+ test? (
+ >=dev-libs/check-0.11.0
+ media-libs/libsndfile
+ )
+"
BDEPEND="
+ dev-util/gdbus-codegen
virtual/pkgconfig
- man? ( app-text/pandoc )
+ man? ( virtual/pandoc )
"
+DOC_CONTENTS="Users can use this service when they are members of the \"audio\" group."
+
src_prepare() {
default
eautoreconf
@@ -55,16 +66,26 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
+ --enable-cli
+ --enable-faststream
+ --enable-midi
--enable-rfcomm
+ --with-bash-completion="$(get_bashcompdir)"
$(use_enable aac)
$(use_enable debug)
$(use_enable lame mp3lame)
$(use_enable man manpages)
$(use_enable mpg123)
$(use_enable static-libs static)
+ $(use_enable systemd)
$(use_enable test)
+ $(use_with systemd systemdsystemunitdir $(systemd_get_systemunitdir))
+ $(multilib_native_use_enable aptx)
+ $(multilib_native_use_enable aptx aptx-hd)
+ $(multilib_native_use_with aptx libfreeaptx)
$(multilib_native_use_enable hcitop)
$(multilib_native_use_enable ldac)
+ $(multilib_native_use_enable liblc3 lc3-swb)
$(multilib_native_use_enable ofono)
$(multilib_native_use_enable upower)
$(use_with unwind libunwind)
@@ -77,14 +98,15 @@ multilib_src_install_all() {
find "${ED}" -type f -name "*.la" -delete || die
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
- newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
- systemd_dounit "${FILESDIR}"/bluealsa.service
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2-r1 bluealsa
# Add config file to alsa datadir as well to preserve changes in /etc
insinto "/usr/share/alsa/alsa.conf.d/"
- doins "src/asound/20-bluealsa.conf"
+ doins "src/asound/20-bluealsa.conf.in"
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
- elog "Users can use this service when they are members of the \"audio\" group."
+ readme.gentoo_print_elog
}