summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/clementine/clementine-1.3.1_p20190127.ebuild')
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20190127.ebuild33
1 files changed, 14 insertions, 19 deletions
diff --git a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
index 6e7d542ac49e..7d23f0ad6e8e 100644
--- a/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20190127.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PLOCALES="af ar be bg bn br bs ca cs cy da de el en en_CA en_GB eo es et eu fa fi fr ga gl he he_IL hi hr hu hy ia id is it ja ka kk ko lt lv mk_MK mr ms my nb nl oc pa pl pt pt_BR ro ru si_LK sk sl sr sr@latin sv te tr tr_TR uk uz vi zh_CN zh_TW"
@@ -9,14 +9,13 @@ MY_P="${P/_}"
if [[ ${PV} == *9999* ]]; then
EGIT_BRANCH="qt5"
EGIT_REPO_URI="https://github.com/clementine-player/Clementine.git"
- GIT_ECLASS="git-r3"
+ inherit git-r3
else
COMMIT=610566d25271c67d1625fd62041f6a27435b0a9d
SRC_URI="https://github.com/${PN}-player/${PN^}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-inherit cmake-utils flag-o-matic gnome2-utils l10n virtualx xdg-utils ${GIT_ECLASS}
-unset GIT_ECLASS
+inherit cmake-utils flag-o-matic l10n virtualx xdg
DESCRIPTION="Modern music player and library organizer based on Amarok 1.4 and Qt"
HOMEPAGE="https://www.clementine-player.org https://github.com/clementine-player/Clementine"
@@ -30,6 +29,16 @@ REQUIRED_USE="
wiimote? ( dbus )
"
+BDEPEND="
+ >=dev-cpp/gtest-1.8.0
+ dev-qt/linguist-tools:5
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-qt/qttest:5
+ gnome-base/gsettings-desktop-schemas
+ )
+"
COMMON_DEPEND="
app-crypt/qca:2[qt5(+)]
dev-db/sqlite:=
@@ -78,24 +87,16 @@ RDEPEND="${COMMON_DEPEND}
udisks? ( sys-fs/udisks:2 )
"
DEPEND="${COMMON_DEPEND}
- >=dev-cpp/gtest-1.8.0
dev-libs/boost
- dev-qt/linguist-tools:5
dev-qt/qtopengl:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
- sys-devel/gettext
- virtual/pkgconfig
box? ( dev-cpp/sparsehash )
dropbox? ( dev-cpp/sparsehash )
googledrive? ( dev-cpp/sparsehash )
pulseaudio? ( media-sound/pulseaudio )
seafile? ( dev-cpp/sparsehash )
skydrive? ( dev-cpp/sparsehash )
- test? (
- dev-qt/qttest:5
- gnome-base/gsettings-desktop-schemas
- )
"
RESTRICT="test"
@@ -166,15 +167,9 @@ src_test() {
}
pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
+ xdg_pkg_postinst
elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
elog "depending on your preferences"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}