summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r2.ebuild')
-rw-r--r--media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r2.ebuild b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r2.ebuild
new file mode 100644
index 000000000000..ce4f80a57ce1
--- /dev/null
+++ b/media-sound/cvoicecontrol/cvoicecontrol-0.9_alpha-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Console based speech recognition system"
+HOMEPAGE="http://www.kiecza.net/daniel/linux/"
+SRC_URI="http://www.kiecza.net/daniel/linux/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo-2.patch
+ "${FILESDIR}"/${P}-tinfo.patch #64716
+ # Handle documentation with HTML_DOCS instead
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ local HTML_DOCS=( cvoicecontrol/docs/en/*.html )
+
+ default
+}