summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/din/din-51.1.1.ebuild')
-rw-r--r--media-sound/din/din-51.1.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/media-sound/din/din-51.1.1.ebuild b/media-sound/din/din-51.1.1.ebuild
deleted file mode 100644
index 43999113438b..000000000000
--- a/media-sound/din/din-51.1.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools edos2unix xdg
-
-DESCRIPTION="a software musical instrument and audio synthesizer"
-HOMEPAGE="https://dinisnoise.org/"
-SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+alsa jack"
-
-RDEPEND="
- dev-lang/tcl:0=
- media-libs/libsdl:=
- virtual/glu
- virtual/opengl
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/boost
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-REQUIRED_USE="|| ( alsa jack )"
-
-PATCHES=(
- "${FILESDIR}/${P}-makefile.patch"
- "${FILESDIR}/${PN}-48-fix-random-constants.patch"
-)
-
-src_prepare() {
- default
-
- edos2unix pixmaps/${PN}.desktop
-
- use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
-
- eautoreconf
-}
-
-src_configure() {
- # Jack takes over alsa.
- local sound_engine
-
- use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
-
- econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
-}