summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/Manifest3
-rw-r--r--media-sound/exaile/exaile-0.3.2.0.ebuild78
-rw-r--r--media-sound/exaile/exaile-0.3.2.1.ebuild73
-rw-r--r--media-sound/exaile/exaile-3.4.5.ebuild59
-rw-r--r--media-sound/exaile/metadata.xml9
5 files changed, 222 insertions, 0 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
new file mode 100644
index 000000000000..7bbb58c66680
--- /dev/null
+++ b/media-sound/exaile/Manifest
@@ -0,0 +1,3 @@
+DIST exaile-0.3.2.0.tar.gz 2082057 SHA256 7571db88db5453d09675ed70d8bd5046825b6e7b79ea76b01707e11cd14609eb
+DIST exaile-0.3.2.1.tar.gz 2061448 SHA256 db3e5b7bb4ad536df31f7f982456ef0aef935021afcd004c8755317584300ff6
+DIST exaile-3.4.5.tar.gz 3662446 SHA256 c875a5c13aa8efb0864d6bafc37e6d3b09f84e251cdb7b77098e6609fb5d00ad SHA512 9337b86ed2f6a13071615bd46a7a05a6564011a4e1fef4cb42925336864c07854cfe497d8defe65c4e287fd9546de6a51543180c5ce6a84525506e57209914be WHIRLPOOL e84c95bab48a9488e2738c16088a3fff333a8af712dd52ac5f0b9d4ce1bdbfc379c2be4fafaf532bb8f44605f1a6ec26cac2e5e96a4a29ba813fdc8b70bbea94
diff --git a/media-sound/exaile/exaile-0.3.2.0.ebuild b/media-sound/exaile/exaile-0.3.2.0.ebuild
new file mode 100644
index 000000000000..d906bb903cf6
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.2.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/${PN}/0.3.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.17
+ >=dev-python/pygobject-2.18:2
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:exec python:exec $(PYTHON):" \
+ exaile tools/generate-launcher || die
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale) || die
+
+ dodoc FUTURE README || die
+
+ if has_version "<media-sound/exaile-0.3"; then
+ insinto /usr/share/exaile/data
+ doins -r data/migrations || die
+ fi
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/exaile-0.3.2.1.ebuild b/media-sound/exaile/exaile-0.3.2.1.ebuild
new file mode 100644
index 000000000000..f3c4e190fbcb
--- /dev/null
+++ b/media-sound/exaile/exaile-0.3.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit fdo-mime multilib python
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://launchpad.net/${PN}/0.3.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+ >=media-libs/mutagen-1.10
+ >=dev-python/pygtk-2.17
+ >=dev-python/pygobject-2.18:2
+ dev-python/gst-python:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ libnotify? ( dev-python/notify-python )
+ cddb? ( dev-python/cddb-py )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:exec python:exec $(PYTHON):" \
+ exaile tools/generate-launcher || die
+}
+
+src_compile() {
+ if use nls; then
+ emake locale || die
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale) || die
+
+ dodoc FUTURE || die
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/exaile-3.4.5.ebuild b/media-sound/exaile/exaile-3.4.5.ebuild
new file mode 100644
index 000000000000..e3670c180112
--- /dev/null
+++ b/media-sound/exaile/exaile-3.4.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit fdo-mime multilib python-r1
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cddb libnotify nls"
+
+RDEPEND="dev-python/dbus-python
+ dev-python/gst-python:0.10
+ >=dev-python/pygtk-2.17
+ >=dev-python/pygobject-2.18:2
+ media-libs/gst-plugins-good:0.10
+ >=media-libs/mutagen-1.10
+ media-plugins/gst-plugins-meta:0.10
+ cddb? ( dev-python/cddb-py )
+ libnotify? ( dev-python/notify-python )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+RESTRICT="test" #315589
+
+src_compile() {
+ if use nls; then
+ emake locale
+ fi
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ dodoc FUTURE
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/metadata.xml b/media-sound/exaile/metadata.xml
new file mode 100644
index 000000000000..70b17978b4e1
--- /dev/null
+++ b/media-sound/exaile/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="launchpad">exaile</remote-id>
+ <remote-id type="github">exaile/exaile</remote-id>
+ </upstream>
+</pkgmetadata>