summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/fapg/fapg-0.43.ebuild')
-rw-r--r--media-sound/fapg/fapg-0.43.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/fapg/fapg-0.43.ebuild b/media-sound/fapg/fapg-0.43.ebuild
new file mode 100644
index 000000000000..e50690223847
--- /dev/null
+++ b/media-sound/fapg/fapg-0.43.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="xspf"
+
+DEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}