summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/flac-image/flac-image-1.00-r2.ebuild')
-rw-r--r--media-sound/flac-image/flac-image-1.00-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/flac-image/flac-image-1.00-r2.ebuild b/media-sound/flac-image/flac-image-1.00-r2.ebuild
new file mode 100644
index 000000000000..210ef0e32715
--- /dev/null
+++ b/media-sound/flac-image/flac-image-1.00-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for adding image files (e.g. album cover art) to metadata of FLAC files"
+HOMEPAGE="http://www.singingtree.com/software/"
+# FIXME: no version in tarball, but also no updates for a long time. So it's ok.
+SRC_URI="http://www.singingtree.com/software/${PN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/flac:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.00-add-missing-string-include.patch
+ "${FILESDIR}"/${PN}-1.00-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ # remove pre-compiled binary
+ rm -f "${PN}" || die
+}
+
+src_install() {
+ dobin "${PN}"
+}