summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/guitarix/guitarix-9999.ebuild')
-rw-r--r--media-sound/guitarix/guitarix-9999.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/media-sound/guitarix/guitarix-9999.ebuild b/media-sound/guitarix/guitarix-9999.ebuild
index 5bd6d0e7b8af..8903dc5a603d 100644
--- a/media-sound/guitarix/guitarix-9999.ebuild
+++ b/media-sound/guitarix/guitarix-9999.ebuild
@@ -1,23 +1,23 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{9..12} )
PYTHON_REQ_USE='threads(+)'
-inherit python-any-r1 waf-utils xdg git-r3
+EGIT_OVERRIDE_REPO_ENYOJS_BOOTPLATE="https://github.com/enyojs/bootplate.git"
+EGIT_OVERRIDE_BRANCH_ENYOJS_BOOTPLATE="master"
-MY_P="${PN}2-${PV}"
+inherit multiprocessing python-any-r1 waf-utils xdg git-r3
DESCRIPTION="Virtual guitar amplifier for Linux"
HOMEPAGE="https://guitarix.org/"
-EGIT_REPO_URI="https://git.code.sf.net/p/guitarix/git"
+EGIT_REPO_URI="https://github.com/brummer10/${PN}.git"
S="${WORKDIR}/${P}/trunk"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
REQUIRED_USE="|| ( lv2 standalone )"
@@ -26,11 +26,11 @@ DEPEND="
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
dev-libs/glib:2
- >=media-libs/libsndfile-1.0.17
- >=media-libs/zita-convolver-3:=
+ media-libs/libsndfile
+ media-libs/zita-convolver:=
media-libs/zita-resampler
- >=net-misc/curl-7.26.0
- >=sci-libs/fftw-3.3.8:3.0=
+ net-misc/curl
+ sci-libs/fftw:3.0=
x11-libs/gtk+:3
lv2? ( media-libs/lv2 )
standalone? (
@@ -65,7 +65,10 @@ BDEPEND="
DOCS=( changelog README )
src_configure() {
+ export -n {CXX,LD}FLAGS
+
local myconf=(
+ --cxxflags="${CXXFLAGS}"
--cxxflags-debug=""
--cxxflags-release="-DNDEBUG"
--ldflags="${LDFLAGS}"
@@ -75,6 +78,7 @@ src_configure() {
--no-faust
--no-ldconfig
--shared-lib
+ --jobs=$(makeopts_jobs)
$(use_enable nls)
$(usex bluetooth "" "--no-bluez")
$(usex debug "--debug" "")