summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/id3ted/id3ted-1.0.ebuild')
-rw-r--r--media-sound/id3ted/id3ted-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-sound/id3ted/id3ted-1.0.ebuild b/media-sound/id3ted/id3ted-1.0.ebuild
new file mode 100644
index 000000000000..8647777f37f4
--- /dev/null
+++ b/media-sound/id3ted/id3ted-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Command-line ID3 Tag Editor"
+HOMEPAGE="https://muennich.github.com/id3ted/"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/taglib
+ sys-apps/file"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-outofbounds.patch" )
+
+pkg_setup() {
+ export PREFIX="/usr"
+ tc-export CXX
+}