summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lmms/lmms-9999.ebuild')
-rw-r--r--media-sound/lmms/lmms-9999.ebuild34
1 files changed, 13 insertions, 21 deletions
diff --git a/media-sound/lmms/lmms-9999.ebuild b/media-sound/lmms/lmms-9999.ebuild
index a92a923b07b8..f525286d2873 100644
--- a/media-sound/lmms/lmms-9999.ebuild
+++ b/media-sound/lmms/lmms-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# The order is important here! Both, cmake and xdg define src_prepare.
-# We need the one from cmake
-inherit xdg cmake
+inherit cmake
DESCRIPTION="Cross-platform music production software"
HOMEPAGE="https://lmms.io"
@@ -13,9 +11,9 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
inherit git-r3
else
- SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+ SRC_URI="https://github.com/LMMS/lmms/releases/download/v${PV/_/-}/${PN}_${PV/_/-}.tar.xz"
+ S="${WORKDIR}/${PN}"
KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${P/_/-}"
fi
LICENSE="GPL-2 LGPL-2"
@@ -43,7 +41,7 @@ COMMON_DEPEND="
media-libs/libvorbis
)
portaudio? ( >=media-libs/portaudio-19_pre )
- pulseaudio? ( media-sound/pulseaudio )
+ pulseaudio? ( media-libs/libpulse )
sdl? (
media-libs/libsdl
>=media-libs/sdl-sound-1.0.1
@@ -68,8 +66,13 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( README.md doc/AUTHORS )
+PATCHES=(
+ "${FILESDIR}/${PN}-9999-no_compress_man.patch" #733284
+ "${FILESDIR}/${PN}-9999-plugin-path.patch" #907285
+)
+
src_configure() {
- local mycmakeargs+=(
+ local mycmakeargs=(
-DUSE_WERROR=FALSE
-DWANT_CAPS=FALSE
-DWANT_TAP=FALSE
@@ -90,17 +93,6 @@ src_configure() {
-DWANT_VST=$(usex vst)
-DWANT_SF2=$(usex fluidsynth)
)
- cmake_src_configure
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-}
-pkg_postrm() {
- xdg_pkg_postrm
+ cmake_src_configure
}