summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild')
-rw-r--r--media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild b/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
new file mode 100644
index 000000000000..df9fb2eda05a
--- /dev/null
+++ b/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A perl script to convert MP3 files to Ogg Vorbis files"
+HOMEPAGE="http://faceprint.com/code/"
+SRC_URI="ftp://ftp.faceprint.com/pub/software/scripts/mp32ogg"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-sound/mpg123
+ dev-perl/MP3-Info
+ dev-perl/String-ShellQuote
+ media-sound/vorbis-tools"
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -f "${DISTDIR}"/${PN} "${WORKDIR}" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-r4-mpg321.patch \
+ "${FILESDIR}"/${P}-r4-quality.patch \
+ "${FILESDIR}"/${P}-r5-german_umlaut.patch \
+ "${FILESDIR}"/${P}-r6-force-filename-stringification.patch
+}
+
+src_install() {
+ dobin mp32ogg || die
+}