summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpdas/mpdas-0.4.5.ebuild')
-rw-r--r--media-sound/mpdas/mpdas-0.4.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/mpdas/mpdas-0.4.5.ebuild b/media-sound/mpdas/mpdas-0.4.5.ebuild
new file mode 100644
index 000000000000..3ef2228a59fe
--- /dev/null
+++ b/media-sound/mpdas/mpdas-0.4.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="AudioScrobbler client for MPD written in C++"
+HOMEPAGE="https://50hz.ws/mpdas/"
+SRC_URI="https://50hz.ws/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ media-libs/libmpdclient
+ net-misc/curl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ tc-export CXX
+ emake CONFIG="/etc"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ dodoc mpdasrc.example README
+}
+
+pkg_postinst() {
+ elog "For further configuration help consult the README in"
+ elog "${EPREFIX}/usr/share/doc/${PF}"
+}