summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pamix/pamix-9999.ebuild')
-rw-r--r--media-sound/pamix/pamix-9999.ebuild40
1 files changed, 23 insertions, 17 deletions
diff --git a/media-sound/pamix/pamix-9999.ebuild b/media-sound/pamix/pamix-9999.ebuild
index 1e8fad344924..e1631975ab6e 100644
--- a/media-sound/pamix/pamix-9999.ebuild
+++ b/media-sound/pamix/pamix-9999.ebuild
@@ -1,38 +1,44 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
inherit git-r3
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
fi
-DESCRIPTION="A PulseAudio NCurses mixer"
+DESCRIPTION="PulseAudio NCurses mixer"
HOMEPAGE="https://github.com/patroclos/PAmix"
+
LICENSE="MIT"
SLOT="0"
IUSE="+unicode"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
-else
- SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/PAmix-${PV}"
-fi
-
-RDEPEND="media-sound/pulseaudio
- sys-libs/ncurses:0=[unicode?]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
+RDEPEND="
+ media-libs/libpulse
+ sys-libs/ncurses:=[unicode(+)?]
"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ cmake_src_prepare
+ if [[ ${PV} != 9999 ]] ; then
+ sed -e "/^include(CMakeGitDefines.cmake)/d" -i CMakeLists.txt || die
+ fi
+}
src_configure() {
local mycmakeargs=(
-DWITH_UNICODE="$(usex unicode)"
)
+ [[ ${PV} != 9999 ]] && mycmakeargs+=( -DGIT_VERSION=${PV} )
cmake_src_configure
}