summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/paprefs/paprefs-1.2-r3.ebuild')
-rw-r--r--media-sound/paprefs/paprefs-1.2-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/paprefs/paprefs-1.2-r3.ebuild b/media-sound/paprefs/paprefs-1.2-r3.ebuild
new file mode 100644
index 000000000000..b6b63e2495f1
--- /dev/null
+++ b/media-sound/paprefs/paprefs-1.2-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic meson xdg
+
+DESCRIPTION="PulseAudio Preferences, configuration dialog for PulseAudio"
+HOMEPAGE="https://freedesktop.org/software/pulseaudio/paprefs"
+SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+RDEPEND="dev-cpp/atkmm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ || ( media-sound/pulseaudio-daemon[glib] media-video/pipewire[gsettings(-)] )
+ x11-libs/gtk+:3
+ || (
+ x11-themes/tango-icon-theme
+ x11-themes/adwaita-icon-theme
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cxxflags -std=c++11 #568590
+
+ local emesonargs=(
+ -Dlynx=false
+ )
+ meson_src_configure
+}