summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pasystray/pasystray-0.2.1.ebuild')
-rw-r--r--media-sound/pasystray/pasystray-0.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/pasystray/pasystray-0.2.1.ebuild b/media-sound/pasystray/pasystray-0.2.1.ebuild
new file mode 100644
index 000000000000..9b9cf4e02ded
--- /dev/null
+++ b/media-sound/pasystray/pasystray-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="A system tray for pulseaudio controls (replacement for the deprecated padevchooser)"
+HOMEPAGE="http://github.com/christophgysin/pasystray"
+SRC_URI="mirror://github/christophgysin/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ || ( >=media-sound/pulseaudio-1.0[glib,avahi] >=media-sound/pulseaudio-5.0-r3[glib,zeroconf] )
+ >=net-dns/avahi-0.6
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README TODO"
+
+src_configure() {
+ econf $(use_enable libnotify notify)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }