summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/patchage')
-rw-r--r--media-sound/patchage/patchage-0.5.0-r2.ebuild10
-rw-r--r--media-sound/patchage/patchage-1.0.0-r1.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/media-sound/patchage/patchage-0.5.0-r2.ebuild b/media-sound/patchage/patchage-0.5.0-r2.ebuild
index ecd4516090e6..98b3a269c3f9 100644
--- a/media-sound/patchage/patchage-0.5.0-r2.ebuild
+++ b/media-sound/patchage/patchage-0.5.0-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit flag-o-matic waf-utils python-any-r1
+inherit flag-o-matic gnome2-utils waf-utils python-any-r1
DESCRIPTION="Modular patch bay for audio and MIDI systems"
HOMEPAGE="http://wiki.drobilla.net/Patchage"
@@ -43,3 +43,11 @@ src_configure() {
$(use alsa || echo "--no-alsa") \
$(use lash || echo "--no-lash")
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/patchage/patchage-1.0.0-r1.ebuild b/media-sound/patchage/patchage-1.0.0-r1.ebuild
index 98c7403ade26..6fe9924872d5 100644
--- a/media-sound/patchage/patchage-1.0.0-r1.ebuild
+++ b/media-sound/patchage/patchage-1.0.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit waf-utils python-any-r1
+inherit gnome2-utils waf-utils python-any-r1
DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
HOMEPAGE="http://drobilla.net/software/patchage"
@@ -38,3 +38,11 @@ src_configure() {
$(use jack-dbus && echo "--jack-dbus") \
$(use session && echo "--jack-session-manage")
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}